summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-03-04 22:22:12 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-03-04 22:22:12 +0000
commit076a62c5f23e2a0ec431479e8342a6d2eca6fcfc (patch)
tree0c7ea5e9aba1904e89391a84cad77238a8360962
parentSet SUPPORT_PYTHON_ABIS (bug #313487). (diff)
downloadgentoo-2-076a62c5f23e2a0ec431479e8342a6d2eca6fcfc.tar.gz
gentoo-2-076a62c5f23e2a0ec431479e8342a6d2eca6fcfc.tar.bz2
gentoo-2-076a62c5f23e2a0ec431479e8342a6d2eca6fcfc.zip
sys-boot/plymouth-0.8.3: Added docs. Better autotools-utils usage.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--sys-boot/plymouth/ChangeLog8
-rw-r--r--sys-boot/plymouth/plymouth-0.8.3.ebuild25
2 files changed, 21 insertions, 12 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index d79a35074555..9698b5ac1443 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/plymouth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.2 2011/02/21 21:54:33 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.3 2011/03/04 22:22:12 aidecoe Exp $
+
+ 04 Mar 2011; Amadeusz Żołnowski <aidecoe@gentoo.org> plymouth-0.8.3.ebuild:
+ Added docs (README and so).
+
+ Used autotools-utils_src_configure instead of manaully calling econf. Thanks
+ to scarabeus@g.o and jlec@g.o for pointing me the error.
21 Feb 2011; Amadeusz Żołnowski <aidecoe@gentoo.org> plymouth-0.8.3.ebuild,
-files/gentoo-logo.png:
diff --git a/sys-boot/plymouth/plymouth-0.8.3.ebuild b/sys-boot/plymouth/plymouth-0.8.3.ebuild
index a0160672df23..cdf9c4d54a44 100644
--- a/sys-boot/plymouth/plymouth-0.8.3.ebuild
+++ b/sys-boot/plymouth/plymouth-0.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3.ebuild,v 1.2 2011/02/21 21:54:33 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3.ebuild,v 1.3 2011/03/04 22:22:12 aidecoe Exp $
-EAPI="3"
+EAPI=3
inherit autotools-utils
@@ -28,6 +28,8 @@ RDEPEND="${DEPEND}
>=sys-kernel/dracut-007
"
+DOCS=(AUTHORS ChangeLog NEWS README TODO)
+
PATCHES=(
"${FILESDIR}"/${PV}-drm-reduce-minimum-build-requirements.patch
"${FILESDIR}"/${PV}-image-replace-deprecated-libpng-function.patch
@@ -36,18 +38,19 @@ PATCHES=(
src_prepare() {
autotools-utils_src_prepare
- eautoreconf || die "eautoreconf failed"
+ eautoreconf
}
src_configure() {
- econf \
- --enable-static=no \
- $(use_enable pango) \
- $(use_enable gdm gdm-transition) \
- $(use_enable video_cards_intel libdrm_intel) \
- $(use_enable video_cards_nouveau libdrm_nouveau) \
- $(use_enable video_cards_radeon libdrm_radeon) \
- || die "econf failed"
+ local myeconfargs=(
+ --enable-static=no
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ $(use_enable video_cards_intel libdrm_intel)
+ $(use_enable video_cards_nouveau libdrm_nouveau)
+ $(use_enable video_cards_radeon libdrm_radeon)
+ )
+ autotools-utils_src_configure
}
src_install() {