summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-17 02:21:57 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-17 02:21:57 +0000
commit4ec132172883c8c4673819e07917f88e74294521 (patch)
tree7a80d8623a0af9429e9c4a32d2a3be4d6424e3b2
parentVersion bump #522904 by Harold Naparst. Import live git ebuild from overlay. (diff)
downloadgentoo-2-4ec132172883c8c4673819e07917f88e74294521.tar.gz
gentoo-2-4ec132172883c8c4673819e07917f88e74294521.tar.bz2
gentoo-2-4ec132172883c8c4673819e07917f88e74294521.zip
Version bump #537920 by José Romildo Malaquias. Import live git ebuild from overlay.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--media-libs/elementary/ChangeLog12
-rw-r--r--media-libs/elementary/elementary-1.13.1.ebuild52
-rw-r--r--media-libs/elementary/elementary-9999.ebuild51
3 files changed, 113 insertions, 2 deletions
diff --git a/media-libs/elementary/ChangeLog b/media-libs/elementary/ChangeLog
index 08d5e76f84d7..a92081236733 100644
--- a/media-libs/elementary/ChangeLog
+++ b/media-libs/elementary/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/elementary
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/ChangeLog,v 1.25 2014/12/31 14:23:07 tommy Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/ChangeLog,v 1.26 2015/03/17 02:21:57 vapier Exp $
+
+*elementary-9999 (17 Mar 2015)
+*elementary-1.13.1 (17 Mar 2015)
+
+ 17 Mar 2015; Mike Frysinger <vapier@gentoo.org> +elementary-1.13.1.ebuild,
+ +elementary-9999.ebuild:
+ Version bump #537920 by José Romildo Malaquias. Import live git ebuild from
+ overlay.
*elementary-1.12.2 (31 Dec 2014)
diff --git a/media-libs/elementary/elementary-1.13.1.ebuild b/media-libs/elementary/elementary-1.13.1.ebuild
new file mode 100644
index 000000000000..013afff1007d
--- /dev/null
+++ b/media-libs/elementary/elementary-1.13.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/elementary-1.13.1.ebuild,v 1.1 2015/03/17 02:21:57 vapier Exp $
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Elementary"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+
+DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-win32
+ --disable-elocation
+ --disable-emap
+ --disable-eweather
+ # broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
+ #$(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ )
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/elementary/elementary-9999.ebuild b/media-libs/elementary/elementary-9999.ebuild
new file mode 100644
index 000000000000..056ca20919d4
--- /dev/null
+++ b/media-libs/elementary/elementary-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/elementary-9999.ebuild,v 1.1 2015/03/17 02:21:57 vapier Exp $
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Elementary"
+
+LICENSE="LGPL-2.1"
+IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+
+DEPEND=">=dev-libs/efl-${PV}[fbcon?,sdl?,png,wayland?,X?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-win32
+ --disable-elocation
+ --disable-emap
+ --disable-eweather
+ # broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
+ #$(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ )
+
+ enlightenment_src_configure
+}