summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-07-03 13:23:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-07-03 13:23:08 +0000
commit86f63248dad017c7ded0443f96d61491f5168003 (patch)
treeb672acd7ec72b4e3417abaf2d07761ae429a3a06
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-86f63248dad017c7ded0443f96d61491f5168003.tar.gz
gentoo-2-86f63248dad017c7ded0443f96d61491f5168003.tar.bz2
gentoo-2-86f63248dad017c7ded0443f96d61491f5168003.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--sys-libs/fortify-headers/ChangeLog10
-rw-r--r--sys-libs/fortify-headers/fortify-headers-0.5.ebuild28
-rw-r--r--sys-libs/fortify-headers/fortify-headers-9999.ebuild28
3 files changed, 64 insertions, 2 deletions
diff --git a/sys-libs/fortify-headers/ChangeLog b/sys-libs/fortify-headers/ChangeLog
index 2d279d853e3a..a5e894ceb22f 100644
--- a/sys-libs/fortify-headers/ChangeLog
+++ b/sys-libs/fortify-headers/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for sys-libs/fortify-headers
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/fortify-headers/ChangeLog,v 1.1 2015/05/15 13:49:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/fortify-headers/ChangeLog,v 1.2 2015/07/03 13:23:08 blueness Exp $
+
+*fortify-headers-0.5 (03 Jul 2015)
+*fortify-headers-9999 (03 Jul 2015)
+
+ 03 Jul 2015; Anthony G. Basile <blueness@gentoo.org>
+ +fortify-headers-0.5.ebuild, +fortify-headers-9999.ebuild:
+ Version bump.
*fortify-headers-0.4 (15 May 2015)
15 May 2015; Anthony G. Basile <blueness@gentoo.org>
+fortify-headers-0.4.ebuild, +metadata.xml:
Initial commit. Bug #546692.
-
diff --git a/sys-libs/fortify-headers/fortify-headers-0.5.ebuild b/sys-libs/fortify-headers/fortify-headers-0.5.ebuild
new file mode 100644
index 000000000000..1d0a30326e63
--- /dev/null
+++ b/sys-libs/fortify-headers/fortify-headers-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/fortify-headers/fortify-headers-0.5.ebuild,v 1.1 2015/07/03 13:23:08 blueness Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
+ inherit git-2
+else
+ SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+DESCRIPTION="A standalone implementation of fortify source."
+HOMEPAGE="http://git.2f30.org/fortify-headers/"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile
+ export DESTDIR="${D}"
+}
diff --git a/sys-libs/fortify-headers/fortify-headers-9999.ebuild b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
new file mode 100644
index 000000000000..4f56ccdd05cc
--- /dev/null
+++ b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/fortify-headers/fortify-headers-9999.ebuild,v 1.1 2015/07/03 13:23:08 blueness Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
+ inherit git-2
+else
+ SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+DESCRIPTION="A standalone implementation of fortify source."
+HOMEPAGE="http://git.2f30.org/fortify-headers/"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile
+ export DESTDIR="${D}"
+}