summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-05-04 15:25:01 +0000
committerBrian Evans <grknight@gentoo.org>2015-05-04 15:25:01 +0000
commit99822d718aeda9d751aebb11d490cb690262fa93 (patch)
tree7c6aa25035cdb0c3f4c9e119336b9f77a2e8f43f
parentebuild improvements, thanks to Nikoli and kensington (diff)
downloadgentoo-2-99822d718aeda9d751aebb11d490cb690262fa93.tar.gz
gentoo-2-99822d718aeda9d751aebb11d490cb690262fa93.tar.bz2
gentoo-2-99822d718aeda9d751aebb11d490cb690262fa93.zip
Version bump; Fix cli USE dep on dev-lang/php wrt bug 538064
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D1F781EFF9F4A3B6)
-rw-r--r--dev-php/phing/ChangeLog7
-rw-r--r--dev-php/phing/phing-2.10.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-php/phing/ChangeLog b/dev-php/phing/ChangeLog
index 48f436333694..c5314b0a3727 100644
--- a/dev-php/phing/ChangeLog
+++ b/dev-php/phing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phing
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.15 2015/04/30 19:51:57 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.16 2015/05/04 15:25:01 grknight Exp $
+
+*phing-2.10.1 (04 May 2015)
+
+ 04 May 2015; Brian Evans <grknight@gentoo.org> +phing-2.10.1.ebuild:
+ Version bump; Fix cli USE dep on dev-lang/php wrt bug 538064
30 Apr 2015; Brian Evans <grknight@gentoo.org> -phing-2.4.9.ebuild,
-phing-2.6.1.ebuild:
diff --git a/dev-php/phing/phing-2.10.1.ebuild b/dev-php/phing/phing-2.10.1.ebuild
new file mode 100644
index 000000000000..1833eca20c52
--- /dev/null
+++ b/dev-php/phing/phing-2.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/phing-2.10.1.ebuild,v 1.1 2015/05/04 15:25:01 grknight Exp $
+
+EAPI="5"
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://www.phing.info/get/phing-${PV}.phar"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( dev-php/phpDocumentor
+ dev-php/PHP_CodeCoverage
+ >=dev-php/PEAR-HTTP_Request2-2.1.1
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php/phpmd-1.1.0
+ >=dev-php/phpunit-4.0
+ >=dev-php/xdebug-2.0.5
+ >=dev-php/simpletest-1.0.1_beta2 )
+ dev-lang/php:*[cli,phar,xml,xslt]
+ "
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/phing
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" phing.phar
+ dosym /usr/share/php/phing/phing.phar /usr/bin/phing
+}
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}