summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-01-11 03:42:02 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-01-11 03:42:02 +0000
commit054047c4d3962992782552b86588d1d526bad40c (patch)
tree2987586d3401144f56277532d3c2cc88fb3ef65d /app-accessibility/brltty
parentamd64 stable, bug 203345 (diff)
downloadgentoo-2-054047c4d3962992782552b86588d1d526bad40c.tar.gz
gentoo-2-054047c4d3962992782552b86588d1d526bad40c.tar.bz2
gentoo-2-054047c4d3962992782552b86588d1d526bad40c.zip
Fixed building with the ocaml use flag -- bug #204789.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog5
-rw-r--r--app-accessibility/brltty/brltty-3.9.ebuild36
2 files changed, 38 insertions, 3 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index fcb64aa46ad0..c59a6deaeee2 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.67 2008/01/05 22:46:49 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.68 2008/01/11 03:42:02 williamh Exp $
+
+ 11 Jan 2008; William Hubbs <williamh@gentoo.org> brltty-3.9.ebuild:
+ Fixed building with the ocaml use flag -- bug #204789.
*brltty-3.9 (05 Jan 2008)
diff --git a/app-accessibility/brltty/brltty-3.9.ebuild b/app-accessibility/brltty/brltty-3.9.ebuild
index b3bceebfb61f..44c73cb06e32 100644
--- a/app-accessibility/brltty/brltty-3.9.ebuild
+++ b/app-accessibility/brltty/brltty-3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.9.ebuild,v 1.2 2008/01/06 07:05:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.9.ebuild,v 1.3 2008/01/11 03:42:02 williamh Exp $
inherit eutils multilib toolchain-funcs
@@ -18,7 +18,7 @@ DEPEND="bluetooth? ( net-wireless/bluez-libs )
iconv? ( virtual/libiconv )
java? ( virtual/jdk )
nls? ( virtual/libintl )
- ocaml? ( >=dev-lang/ocaml-3.09.3-r1 )
+ ocaml? ( >=dev-ml/findlib-1.0.4-r1 )
python? ( >=dev-python/pyrex-0.9.4.1 )
tcl? ( >=dev-lang/tcl-8.4.15 )
usb? ( >=dev-libs/libusb-0.1.12-r1 )
@@ -40,7 +40,39 @@ src_compile() {
emake || die
}
+# The following was copied from findlib.eclass so that we don't force a
+# dependency on dev-ml/findlib unless the ml use flag is on.
+
+check_ocamlfind() {
+ if [ ! -x /usr/bin/ocamlfind ]
+ then
+ ewarn "In findlib.eclass: could not find the ocamlfind executable"
+ ewarn "Please report this bug on gentoo's bugzilla, assigning to ml@gentoo.org"
+ exit 1
+ fi
+}
+
+# Prepare the image for a findlib installation.
+# We use the stublibs style, so no ld.conf needs to be
+# updated when a package installs C shared libraries.
+findlib_src_preinst() {
+ check_ocamlfind
+
+ # destdir is the ocaml sitelib
+ local destdir=`ocamlfind printconf destdir`
+
+ dodir ${destdir} || die "dodir failed"
+ export OCAMLFIND_DESTDIR=${D}${destdir}
+
+ # stublibs style
+ dodir ${destdir}/stublibs || die "dodir failed"
+ export OCAMLFIND_LDCONF=ignore
+}
+
src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
make INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT="${D}" install || die
cd Documents