summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-13 14:40:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-13 14:40:52 +0000
commit5a6c986dfcc04d918f1410289c426eda536247e4 (patch)
treed47e24bc6708abc1c16f6e9837dc59ac709f0760 /app-admin
parent"Stable x86, bug #147570" (diff)
downloadgentoo-2-5a6c986dfcc04d918f1410289c426eda536247e4.tar.gz
gentoo-2-5a6c986dfcc04d918f1410289c426eda536247e4.tar.bz2
gentoo-2-5a6c986dfcc04d918f1410289c426eda536247e4.zip
Remove xmms and infopipe useflags.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/conky/ChangeLog6
-rw-r--r--app-admin/conky/conky-1.4.0-r1.ebuild9
-rw-r--r--app-admin/conky/conky-1.4.2.ebuild9
3 files changed, 11 insertions, 13 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 791545b26c06..2286778f1eb0 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.35 2006/11/12 12:24:35 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.36 2006/11/13 14:40:52 flameeyes Exp $
+
+ 13 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> conky-1.4.0-r1.ebuild,
+ conky-1.4.2.ebuild:
+ Remove xmms and infopipe useflags.
12 Nov 2006; Daniel Black <dragonheart@gentoo.org>
-files/conky-1.3.4-arraybounds.patch, -files/conky-1.3.4-miscbug.patch,
diff --git a/app-admin/conky/conky-1.4.0-r1.ebuild b/app-admin/conky/conky-1.4.0-r1.ebuild
index 096ce9e419b2..b2bfd86d2333 100644
--- a/app-admin/conky/conky-1.4.0-r1.ebuild
+++ b/app-admin/conky/conky-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.4.0-r1.ebuild,v 1.7 2006/05/21 09:10:37 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.4.0-r1.ebuild,v 1.8 2006/11/13 14:40:52 flameeyes Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="truetype X ipv6 xmms infopipe audacious"
+IUSE="truetype X ipv6 audacious"
DEPEND_COMMON="
virtual/libc
@@ -27,8 +27,6 @@ DEPEND_COMMON="
)
truetype? ( >=media-libs/freetype-2 )
audacious? ( media-sound/audacious )
- infopipe? ( media-plugins/xmms-infopipe )
- xmms? ( media-sound/xmms )
)"
RDEPEND="${DEPEND_COMMON}"
@@ -69,11 +67,10 @@ src_compile() {
--enable-mpd --enable-mldonkey --disable-bmpx"
econf \
${myconf} \
+ --disable-xmms --disable-infopipe \
$(use_enable truetype xft) \
$(use_enable X x11) \
- $(use_enable xmms) \
$(use_enable audacious) \
- $(use_enable infopipe) \
$(use_enable !ipv6 portmon) || die "econf failed"
emake ${mymake} || die "compile failed"
}
diff --git a/app-admin/conky/conky-1.4.2.ebuild b/app-admin/conky/conky-1.4.2.ebuild
index 18fe635b0d31..9deb43c9036e 100644
--- a/app-admin/conky/conky-1.4.2.ebuild
+++ b/app-admin/conky/conky-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.4.2.ebuild,v 1.3 2006/06/11 20:23:09 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.4.2.ebuild,v 1.4 2006/11/13 14:40:52 flameeyes Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="truetype X ipv6 bmpx xmms infopipe audacious"
+IUSE="truetype X ipv6 bmpx audacious"
DEPEND_COMMON="
virtual/libc
@@ -30,8 +30,6 @@ DEPEND_COMMON="
>=sys-apps/dbus-0.35
)
audacious? ( media-sound/audacious )
- infopipe? ( media-plugins/xmms-infopipe )
- xmms? ( media-sound/xmms )
)"
RDEPEND="${DEPEND_COMMON}"
@@ -66,12 +64,11 @@ src_compile() {
--enable-mpd --enable-mldonkey"
econf \
${myconf} \
+ --disable-xmms --disable-infopipe \
$(use_enable truetype xft) \
$(use_enable X x11) \
$(use_enable bmpx) \
- $(use_enable xmms) \
$(use_enable audacious) \
- $(use_enable infopipe) \
$(use_enable !ipv6 portmon) || die "econf failed"
emake ${mymake} || die "compile failed"
}