summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-04 07:17:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-04 07:17:27 +0000
commit8598dcec64788688937dfefc771179aebe9b6fc0 (patch)
treed9b5a2512d5e8fbd61402da24f231a01ffcdff1c /app-arch
parentRemove old. (diff)
downloadgentoo-2-8598dcec64788688937dfefc771179aebe9b6fc0.tar.gz
gentoo-2-8598dcec64788688937dfefc771179aebe9b6fc0.tar.bz2
gentoo-2-8598dcec64788688937dfefc771179aebe9b6fc0.zip
Version bump
(Portage version: 2.2_rc64/cvs/Linux i686)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lbzip2/ChangeLog8
-rw-r--r--app-arch/lbzip2/lbzip2-0.23.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index 7bc64fbf9238..b242d93c7a22 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.3 2010/02/19 09:20:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.4 2010/03/04 07:17:27 jlec Exp $
+
+*lbzip2-0.23 (04 Mar 2010)
+
+ 04 Mar 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +lbzip2-0.23.ebuild:
+ Version Bump
*lbzip2-0.22 (19 Feb 2010)
diff --git a/app-arch/lbzip2/lbzip2-0.23.ebuild b/app-arch/lbzip2/lbzip2-0.23.ebuild
new file mode 100644
index 000000000000..780508098233
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-0.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23.ebuild,v 1.1 2010/03/04 07:17:27 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Pthreads-based parallel bzip2/bunzip2 filter, passable to GNU tar"
+HOMEPAGE="http://lacos.hu/"
+SRC_URI="http://lacos.web.elte.hu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink test"
+
+RDEPEND="app-arch/bzip2"
+DEPEND="${REDEPEND}
+ test? (
+ app-shells/dash
+ sys-process/time
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+# epatch "${FILESDIR}"/${PV}-Makefile.patch
+ epatch "${FILESDIR}"/0.22-Makefile.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_test() {
+ if [ -t 0 ] || return; then
+ rm -rf "${T}/scratch" "${T}/results" "${T}/rnd"
+ hexdump -n 10485760 /dev/urandom > "${T}/rnd"
+ emake -j1 SHELL="${EPREFIX}"/bin/dash PATH="${S}:${PATH}" TESTFILE="${T}/rnd" check \
+ || die "make check failed"
+ else
+ ewarn "make check must be run attached to a terminal"
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die "Installation of ${PN} failed"
+ dodoc ChangeLog README || die "no docs"
+ doman ${PN}.1 || die "no man"
+ insinto /usr/share/${PN}
+ doins corr-perf.sh malloc_trace.pl || die
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/gzip || die
+ dosym un${PN} /usr/bin/gunzip || die
+ fi
+}