summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-28 03:07:37 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-28 03:07:37 +0000
commit8ae90d0c7f3cd5882ff01aac8dfefbcfa4b75b93 (patch)
tree6b42c98ed0b53ce588eed12e68d323c92d8b3f32 /app-arch
parentversion bump; now supports gpo.zugiana.org as a secondary (or primary, if USE... (diff)
downloadgentoo-2-8ae90d0c7f3cd5882ff01aac8dfefbcfa4b75b93.tar.gz
gentoo-2-8ae90d0c7f3cd5882ff01aac8dfefbcfa4b75b93.tar.bz2
gentoo-2-8ae90d0c7f3cd5882ff01aac8dfefbcfa4b75b93.zip
Clean up build a bit and use Debian patches.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unace/ChangeLog9
-rw-r--r--app-arch/unace/files/unace-1.2b-64bit-fmt.patch20
-rw-r--r--app-arch/unace/files/unace-1.2b-aliasing.patch20
-rw-r--r--app-arch/unace/unace-1.2b-r2.ebuild47
4 files changed, 95 insertions, 1 deletions
diff --git a/app-arch/unace/ChangeLog b/app-arch/unace/ChangeLog
index 28d11269ddd6..c57653c57827 100644
--- a/app-arch/unace/ChangeLog
+++ b/app-arch/unace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/unace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/ChangeLog,v 1.46 2013/02/20 09:54:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/ChangeLog,v 1.47 2013/03/28 03:07:37 vapier Exp $
+
+*unace-1.2b-r2 (28 Mar 2013)
+
+ 28 Mar 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/unace-1.2b-64bit-fmt.patch, +files/unace-1.2b-aliasing.patch,
+ +unace-1.2b-r2.ebuild:
+ Clean up build a bit and use Debian patches.
20 Feb 2013; Agostino Sarubbo <ago@gentoo.org> unace-2.5-r2.ebuild:
Stable for s390, wrt bug #431696
diff --git a/app-arch/unace/files/unace-1.2b-64bit-fmt.patch b/app-arch/unace/files/unace-1.2b-64bit-fmt.patch
new file mode 100644
index 000000000000..a7cdff7aca30
--- /dev/null
+++ b/app-arch/unace/files/unace-1.2b-64bit-fmt.patch
@@ -0,0 +1,20 @@
+--- unace/unace.c
++++ unace/unace.c
+@@ -516,7 +516,7 @@
+ tpsize+= fhead.PSIZE;
+ }
+ if (!f_err)
+- printf("%02u.%02u.%02u|%02u:%02u|%c%c%9lu|%9lu|%4u%%|%c%s\n",
++ printf("%02u.%02u.%02u|%02u:%02u|%c%c%9u|%9u|%4u%%|%c%s\n",
+ ts_day (ti), ts_month(ti), ts_year(ti)%100,
+ ts_hour(ti), ts_min (ti),
+ fhead.HEAD_FLAGS & ACE_SP_BEF ? '<' : ' ',
+@@ -529,7 +529,7 @@
+ }
+ if (!f_err)
+ {
+- printf("\n %9lu|%9lu|%4u%%| %u file%s",
++ printf("\n %9u|%9u|%4u%%| %u file%s",
+ psize,
+ size,
+ percentage(psize, size),
diff --git a/app-arch/unace/files/unace-1.2b-aliasing.patch b/app-arch/unace/files/unace-1.2b-aliasing.patch
new file mode 100644
index 000000000000..ccd7f57c4f98
--- /dev/null
+++ b/app-arch/unace/files/unace-1.2b-aliasing.patch
@@ -0,0 +1,20 @@
+--- a/portable.h
++++ b/portable.h
+@@ -79,11 +79,13 @@
+
+ #else /* HI_LO_BYTE_ORDER */
+
+-#define BUFP2WORD(p) *(UWORD*)((p+=2)-2)
+-#define BUFP2LONG(p) *(ULONG*)((p+=4)-4)
++#define _MAGIC_UNION(type, p) ({ union { UCHAR *_c; type *_u; } _x = { ._c = (p) }; *_x._u; })
+
+-#define BUF2WORD(p) (*(UWORD*)p)
+-#define BUF2LONG(p) (*(ULONG*)p)
++#define BUFP2WORD(p) _MAGIC_UNION(UWORD, ((p+=2)-2))
++#define BUFP2LONG(p) _MAGIC_UNION(ULONG, ((p+=4)-4))
++
++#define BUF2WORD(p) _MAGIC_UNION(UWORD, p)
++#define BUF2LONG(p) _MAGIC_UNION(ULONG, p)
+
+ #endif /* !HI_LO_BYTE_ORDER */
+
diff --git a/app-arch/unace/unace-1.2b-r2.ebuild b/app-arch/unace/unace-1.2b-r2.ebuild
new file mode 100644
index 000000000000..dd1c5451e2c2
--- /dev/null
+++ b/app-arch/unace/unace-1.2b-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-1.2b-r2.ebuild,v 1.1 2013/03/28 03:07:37 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DEB_VER="10"
+DESCRIPTION="ACE unarchiver"
+HOMEPAGE="http://www.winace.com/"
+SRC_URI="mirror://debian/pool/main/u/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/u/${PN}/${PN}_${PV}-${DEB_VER}.debian.tar.gz"
+
+LICENSE="GPL-2" #92846
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~s390 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}${PV}
+
+src_prepare() {
+ epatch $(sed 's:^:../debian/patches/:' "${WORKDIR}"/debian/patches/series)
+ epatch "${FILESDIR}"/${P}-64bit-fmt.patch
+ epatch "${FILESDIR}"/${P}-aliasing.patch
+ cp unix/{makefile,gccmaked} . || die
+}
+
+src_configure() {
+ sed -i \
+ -e '/^OSTYPE =/s:=.*:= Linux:' \
+ -e "/^CFLAGS =/s:=.*:+= -Wall:" \
+ -e "/^CC =/s:=.*:= $(tc-getCC):" \
+ -e 's/-DCASEINSENSE//g' \
+ makefile || die
+}
+
+src_compile() {
+ emake dep
+ emake
+}
+
+src_install() {
+ dobin unace
+ dodoc unix/readme.txt changes.log
+ doman ../debian/unace.1
+}