summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-04-06 22:51:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-04-06 22:51:08 +0000
commit62b3277921939f1386d01fdbe107f418d846e729 (patch)
treeb3a09ec7783bff19244b971180420a9e6ab3d683 /app-benchmarks
parentVersion bump (diff)
downloadgentoo-2-62b3277921939f1386d01fdbe107f418d846e729.tar.gz
gentoo-2-62b3277921939f1386d01fdbe107f418d846e729.tar.bz2
gentoo-2-62b3277921939f1386d01fdbe107f418d846e729.zip
Initial commit.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/spew/ChangeLog8
-rw-r--r--app-benchmarks/spew/files/remove-symlinks-makefile.patch26
-rw-r--r--app-benchmarks/spew/metadata.xml13
-rw-r--r--app-benchmarks/spew/spew-1.0.8.ebuild37
4 files changed, 84 insertions, 0 deletions
diff --git a/app-benchmarks/spew/ChangeLog b/app-benchmarks/spew/ChangeLog
new file mode 100644
index 000000000000..36513c770b4d
--- /dev/null
+++ b/app-benchmarks/spew/ChangeLog
@@ -0,0 +1,8 @@
+
+
+*spew-1.0.8 (06 Apr 2011)
+
+ 06 Apr 2011; Anthony G. Basile <blueness@gentoo.org> +spew-1.0.8.ebuild,
+ +files/remove-symlinks-makefile.patch, +metadata.xml:
+ Initial commit.
+
diff --git a/app-benchmarks/spew/files/remove-symlinks-makefile.patch b/app-benchmarks/spew/files/remove-symlinks-makefile.patch
new file mode 100644
index 000000000000..e5c369a7f8a0
--- /dev/null
+++ b/app-benchmarks/spew/files/remove-symlinks-makefile.patch
@@ -0,0 +1,26 @@
+diff -Naur spew-1.0.8.orig/man/Makefile.am spew-1.0.8/man/Makefile.am
+--- spew-1.0.8.orig/man/Makefile.am 2008-05-13 00:47:28.000000000 -0400
++++ spew-1.0.8/man/Makefile.am 2011-04-05 09:39:32.000000000 -0400
+@@ -10,11 +10,5 @@
+ sed -e 's!SPEW_VERSION!$(VERSION)!' \
+ -e 's!SYSCONFDIR!$(sysconfdir)!' $< >$@
+
+-install-data-am: install-man install-man-local
+-
+-install-man-local:
+- (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) -f spew.1 gorge.1)
+- (cd $(DESTDIR)$(mandir)/man1 && $(LN_S) -f spew.1 regorge.1)
+-
+ help2man:
+ help2man --section=1 --no-info --name="measures I/O performance and/or generates I/O load" --include="spew.1.include" --output=spew.1.in ../src/spew
+diff -Naur spew-1.0.8.orig/src/Makefile.am spew-1.0.8/src/Makefile.am
+--- spew-1.0.8.orig/src/Makefile.am 2008-05-13 00:47:20.000000000 -0400
++++ spew-1.0.8/src/Makefile.am 2011-04-05 09:35:16.000000000 -0400
+@@ -38,7 +38,3 @@
+ SpewTuiStatusWindow.cpp SpewTuiStatusWindow.h
+
+ spew_LDFLAGS = $(STATIC_LINK)
+-
+-install-exec-local:
+- (cd $(DESTDIR)$(bindir) && $(LN_S) -f spew gorge)
+- (cd $(DESTDIR)$(bindir) && $(LN_S) -f spew regorge)
diff --git a/app-benchmarks/spew/metadata.xml b/app-benchmarks/spew/metadata.xml
new file mode 100644
index 000000000000..5234f3362711
--- /dev/null
+++ b/app-benchmarks/spew/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription lang="en">
+ An I/O performance measurement and load generation tool. Writes
+ and/or reads generated data to or from a character device, block
+ device, or regular file.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-benchmarks/spew/spew-1.0.8.ebuild b/app-benchmarks/spew/spew-1.0.8.ebuild
new file mode 100644
index 000000000000..adf4dbd33ec5
--- /dev/null
+++ b/app-benchmarks/spew/spew-1.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.1 2011/04/06 22:51:08 blueness Exp $
+
+EAPI=3
+
+inherit autotools eutils
+
+DESCRIPTION="Measures I/O performance and/or generates I/O load"
+HOMEPAGE="http://spew.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/spew/1.0.8/spew-1.0.8.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static"
+
+DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
+ !static? ( sys-libs/ncurses dev-libs/popt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/remove-symlinks-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dosym ${PN} /usr/bin/gorge
+ dosym ${PN} /usr/bin/regorge
+ dosym ${PN}.1.bz2 /usr/share/man/man1/gorge.1.bz2
+ dosym ${PN}.1.bz2 /usr/share/man/man1/reorge.1.bz2
+}