summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-11 20:06:07 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-11 20:06:07 +0000
commit57a4d313165513a52b3d405b9a1fa7a925b93dd1 (patch)
tree046a3863876fe752f721d4940eaf6de1d2456c63 /app-cdr
parenteroaster 2.1.0 masked (diff)
downloadgentoo-2-57a4d313165513a52b3d405b9a1fa7a925b93dd1.tar.gz
gentoo-2-57a4d313165513a52b3d405b9a1fa7a925b93dd1.tar.bz2
gentoo-2-57a4d313165513a52b3d405b9a1fa7a925b93dd1.zip
Eroaster development version added, but *masked*. Closes bug #4250.
Also added KEYWORDS in the eroaster-2.0.12 ebuild
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/eroaster/ChangeLog11
-rw-r--r--app-cdr/eroaster/eroaster-2.0.12.ebuild3
-rw-r--r--app-cdr/eroaster/eroaster-2.1.0.ebuild56
-rw-r--r--app-cdr/eroaster/files/digest-eroaster-2.1.01
4 files changed, 68 insertions, 3 deletions
diff --git a/app-cdr/eroaster/ChangeLog b/app-cdr/eroaster/ChangeLog
index 3ae41572b94b..e5f795576ce5 100644
--- a/app-cdr/eroaster/ChangeLog
+++ b/app-cdr/eroaster/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for app-cdr/arson
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# Author: Mark Dillavou <line72@postmark.net>
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/eroaster/ChangeLog,v 1.1 2002/07/05 10:19:41 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/eroaster/ChangeLog,v 1.2 2002/07/11 20:06:07 stroke Exp $
+
+*eroaster-2.1.0 (11 July 2002)
+
+ 11 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> eroaster-2.1.0.ebuild:
+
+ Eroaster development version added, but *masked*. Closes bug #4250.
+ Ebuild submitted by: Philip Walls <malverian@hotmail.com>
*eroaster-2.0.12 (5 July 2002) Bart Verwilst <verwilst@gentoo.org>
initial ebuild
+ ebuild written by Mark Dillavou <line72@postmark.net>
diff --git a/app-cdr/eroaster/eroaster-2.0.12.ebuild b/app-cdr/eroaster/eroaster-2.0.12.ebuild
index f3528e1aa377..93711ba2001c 100644
--- a/app-cdr/eroaster/eroaster-2.0.12.ebuild
+++ b/app-cdr/eroaster/eroaster-2.0.12.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/eroaster/eroaster-2.0.12.ebuild,v 1.2 2002/07/06 20:51:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/eroaster/eroaster-2.0.12.ebuild,v 1.3 2002/07/11 20:06:07 stroke Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Awesome CD burning frontend"
SLOT="0"
SRC_URI="ftp://eclipt.uni-klu.ac.at/pub/projects/eroaster/${P}.tar.gz"
LICENSE="GPL-2"
+KEYWORDS="*"
HOMEPAGE="http://eclipt.uni-klu.ac.at/eroaster.php"
DEPEND=">=dev-lang/python-2.0
diff --git a/app-cdr/eroaster/eroaster-2.1.0.ebuild b/app-cdr/eroaster/eroaster-2.1.0.ebuild
new file mode 100644
index 000000000000..c91cdb7cd781
--- /dev/null
+++ b/app-cdr/eroaster/eroaster-2.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/eroaster/eroaster-2.1.0.ebuild,v 1.1 2002/07/11 20:06:07 stroke Exp $
+
+DESCRIPTION="A graphical frontend for cdrecord and mkisofs written in gnome-python"
+HOMEPAGE="http://eroaster.sourceforge.net"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/eroaster/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="*"
+SLOT="0"
+
+# cdrecord and mkisofs are needed or configure fails
+DEPEND=">=dev-lang/python-2.0
+ >=dev-python/gnome-python-1.4
+ app-cdr/cdrtools
+ sys-apps/mkisofs"
+
+# xmms here is only used in runtime
+# not a bulild dep.
+RDEPEND="${DEPEND}
+ xmms? ( media-sound/xmms-1.2.7 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The following binaries are needed to make full use of this program:"
+ einfo
+ einfo "mpg123 For converting MP3s to WAVs and playing MP3s"
+ einfo "sox For converting MP3s to WAVs"
+ einfo "xmms For playing MP3s"
+ einfo "bchunk For converting BIN/CUE to ISO"
+ einfo "lame For Encoding MP3s"
+ einfo "ogginfo For Getting OGG ID3 information"
+ einfo "ogg123 For converting OGGs to WAVs"
+ einfo
+}
diff --git a/app-cdr/eroaster/files/digest-eroaster-2.1.0 b/app-cdr/eroaster/files/digest-eroaster-2.1.0
new file mode 100644
index 000000000000..d5e22611df6b
--- /dev/null
+++ b/app-cdr/eroaster/files/digest-eroaster-2.1.0
@@ -0,0 +1 @@
+MD5 1337d58a0c140ef62f2184699132ed40 eroaster-2.1.0.tar.gz 160884