summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-09-27 07:29:21 +0000
committerTim Harder <radhermit@gentoo.org>2013-09-27 07:29:21 +0000
commit87fb99e3e8a9c4135c14642e35cb2d548e97ed1b (patch)
treececb3ad1fa58674f442d8bc24bc0fe5dd7de7ae9 /app-crypt/p11-kit
parentVersion bump and update to EAPI 5 (bug #466018). (diff)
downloadgentoo-2-87fb99e3e8a9c4135c14642e35cb2d548e97ed1b.tar.gz
gentoo-2-87fb99e3e8a9c4135c14642e35cb2d548e97ed1b.tar.bz2
gentoo-2-87fb99e3e8a9c4135c14642e35cb2d548e97ed1b.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/ChangeLog7
-rw-r--r--app-crypt/p11-kit/p11-kit-0.20.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/app-crypt/p11-kit/ChangeLog b/app-crypt/p11-kit/ChangeLog
index dd5d7b195f90..aa1103c1b028 100644
--- a/app-crypt/p11-kit/ChangeLog
+++ b/app-crypt/p11-kit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/p11-kit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.50 2013/09/01 18:54:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/ChangeLog,v 1.51 2013/09/27 07:29:21 radhermit Exp $
+
+*p11-kit-0.20.1 (27 Sep 2013)
+
+ 27 Sep 2013; Tim Harder <radhermit@gentoo.org> +p11-kit-0.20.1.ebuild:
+ Version bump.
01 Sep 2013; Tim Harder <radhermit@gentoo.org> p11-kit-0.19.4.ebuild:
Remove unused autotools eclass.
diff --git a/app-crypt/p11-kit/p11-kit-0.20.1.ebuild b/app-crypt/p11-kit/p11-kit-0.20.1.ebuild
new file mode 100644
index 000000000000..1178ab04bb28
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.20.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/p11-kit/p11-kit-0.20.1.ebuild,v 1.1 2013/09/27 07:29:21 radhermit Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11."
+HOMEPAGE="http://p11-glue.freedesktop.org/p11-kit.html"
+SRC_URI="http://p11-glue.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asn1 debug +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-2.14 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable trust trust-module) \
+ $(use_enable debug) \
+ $(use_with asn1 libtasn1)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}