summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-10-07 20:58:00 +0000
committerUlrich Müller <ulm@gentoo.org>2011-10-07 20:58:00 +0000
commitee854d3eb3af188e780a1f7fbcfb0608c7adfbd5 (patch)
treea400b746c2fc8efca305c90706d7e0e609c14988 /app-emacs/pymacs
parenthdaps-gl respect CC and EAPI 4 (diff)
downloadgentoo-2-ee854d3eb3af188e780a1f7fbcfb0608c7adfbd5.tar.gz
gentoo-2-ee854d3eb3af188e780a1f7fbcfb0608c7adfbd5.tar.bz2
gentoo-2-ee854d3eb3af188e780a1f7fbcfb0608c7adfbd5.zip
Version bump and support for Python 3, bug 385259.
(Portage version: 2.1.10.22/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/ChangeLog7
-rw-r--r--app-emacs/pymacs/pymacs-0.23-r1.ebuild5
-rw-r--r--app-emacs/pymacs/pymacs-0.24_beta2.ebuild47
3 files changed, 55 insertions, 4 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
index 6be7b354a2e3..6084be9e39e4 100644
--- a/app-emacs/pymacs/ChangeLog
+++ b/app-emacs/pymacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/pymacs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.54 2011/10/05 19:29:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.55 2011/10/07 20:58:00 ulm Exp $
+
+*pymacs-0.24_beta2 (07 Oct 2011)
+
+ 07 Oct 2011; Ulrich Mueller <ulm@gentoo.org> +pymacs-0.24_beta2.ebuild:
+ Version bump and support for Python 3, bug 385259.
05 Oct 2011; Alexis Ballier <aballier@gentoo.org> pymacs-0.23-r1.ebuild:
remove ptex dep as it is going away
diff --git a/app-emacs/pymacs/pymacs-0.23-r1.ebuild b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
index cbd5a3666e94..ebef8218b520 100644
--- a/app-emacs/pymacs/pymacs-0.23-r1.ebuild
+++ b/app-emacs/pymacs/pymacs-0.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23-r1.ebuild,v 1.10 2011/10/05 19:29:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.23-r1.ebuild,v 1.11 2011/10/07 20:58:00 ulm Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -22,8 +22,7 @@ DEPEND="
doc? ( dev-python/docutils
virtual/latex-base
dev-texlive/texlive-latexextra
- dev-texlive/texlive-langfrench
- )"
+ dev-texlive/texlive-langfrench )"
RDEPEND=""
SITEFILE=50${PN}-gentoo.el
diff --git a/app-emacs/pymacs/pymacs-0.24_beta2.ebuild b/app-emacs/pymacs/pymacs-0.24_beta2.ebuild
new file mode 100644
index 000000000000..e17af67f2adc
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.24_beta2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.24_beta2.ebuild,v 1.1 2011/10/07 20:58:00 ulm Exp $
+
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+
+inherit distutils elisp
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+# taken from https://github.com/pinard/Pymacs/tarball/v0.24-beta2
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( >=dev-python/docutils-0.7
+ virtual/latex-base )"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ mv pinard-Pymacs-* "${S}" || die
+}
+
+src_compile() {
+ emake || die
+ elisp-compile pymacs.el || die
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts \
+ emake RST2LATEX=rst2latex.py pymacs.pdf || die
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ distutils_src_install
+ dodoc THANKS pymacs.rst || die
+ if use doc; then
+ dodoc pymacs.pdf || die
+ fi
+}