summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-03-19 18:36:15 +0000
committerUlrich Müller <ulm@gentoo.org>2012-03-19 18:36:15 +0000
commite585d59a8b4738daa9583112d86354b2b612cde1 (patch)
treeec9db2517684163ae757872c64e00eb90738793b /app-emacs/riece/riece-8.0.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-e585d59a8b4738daa9583112d86354b2b612cde1.tar.gz
gentoo-2-e585d59a8b4738daa9583112d86354b2b612cde1.tar.bz2
gentoo-2-e585d59a8b4738daa9583112d86354b2b612cde1.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/riece/riece-8.0.0.ebuild')
-rw-r--r--app-emacs/riece/riece-8.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-8.0.0.ebuild b/app-emacs/riece/riece-8.0.0.ebuild
new file mode 100644
index 000000000000..7a4c2eb0902a
--- /dev/null
+++ b/app-emacs/riece/riece-8.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-8.0.0.ebuild,v 1.1 2012/03/19 18:36:15 ulm Exp $
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="A redesign of Liece IRC client"
+HOMEPAGE="http://www.nongnu.org/riece/"
+SRC_URI="http://download.savannah.gnu.org/releases/riece/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="linguas_ja"
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${SITELISP}"
+}
+
+src_compile() {
+ default
+}
+
+src_install () {
+ einstall lispdir="${D}/${SITELISP}"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ dodoc AUTHORS NEWS README doc/HACKING lisp/ChangeLog*
+
+ if use linguas_ja; then
+ dodoc NEWS.ja README.ja doc/HACKING.ja
+ else
+ rm -f "${D}"/usr/share/info/riece-ja.info*
+ fi
+}