summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-12-30 07:03:42 +0000
committerAlec Warner <antarus@gentoo.org>2006-12-30 07:03:42 +0000
commit0963efa69ef2bb9aff28088845592cc647622b5e (patch)
tree86d2e9f21a19d8a0e18a2b6f4f92086117023abb /app-emulation/frodo/files
parentdont bother moving consolelog.sh to /sbin since metalog itself is still in /usr (diff)
downloadgentoo-2-0963efa69ef2bb9aff28088845592cc647622b5e.tar.gz
gentoo-2-0963efa69ef2bb9aff28088845592cc647622b5e.tar.bz2
gentoo-2-0963efa69ef2bb9aff28088845592cc647622b5e.zip
Fix SRC_URI, rename properly
(Portage version: 5386-svn)
Diffstat (limited to 'app-emulation/frodo/files')
-rw-r--r--app-emulation/frodo/files/digest-frodo-4.1b3
-rw-r--r--app-emulation/frodo/files/frodo-4.1b-gentoo.diff83
2 files changed, 86 insertions, 0 deletions
diff --git a/app-emulation/frodo/files/digest-frodo-4.1b b/app-emulation/frodo/files/digest-frodo-4.1b
new file mode 100644
index 000000000000..da2b88760ab2
--- /dev/null
+++ b/app-emulation/frodo/files/digest-frodo-4.1b
@@ -0,0 +1,3 @@
+MD5 095b9f21c03204cc13f7f249e8866cd9 FrodoV4_1b.Src.tar.gz 377002
+RMD160 b08231f0f1121d4f802ce08407a6e6c371905bd3 FrodoV4_1b.Src.tar.gz 377002
+SHA256 ffae146dc20458698acf5ccc384dc32317cea1df0c95b44b5d47cca8b26bc986 FrodoV4_1b.Src.tar.gz 377002
diff --git a/app-emulation/frodo/files/frodo-4.1b-gentoo.diff b/app-emulation/frodo/files/frodo-4.1b-gentoo.diff
new file mode 100644
index 000000000000..97591fd6e66f
--- /dev/null
+++ b/app-emulation/frodo/files/frodo-4.1b-gentoo.diff
@@ -0,0 +1,83 @@
+--- configure.in.orig 2003-04-17 03:59:57.000000000 -0400
++++ configure.in 2003-04-17 04:00:28.000000000 -0400
+@@ -10,11 +10,6 @@
+ AC_PROG_CPP
+ AC_PROG_MAKE_SET
+
+-dnl Don't want the default "-O2 -g" that autoconf uses for gcc.
+-if [[ x"$GXX" = "xyes" ]]; then
+- CFLAGS="-O2 -g -fomit-frame-pointer -Wall -Wno-unused -Wno-format"
+-fi
+-
+ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
+ UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
+
+--- C64_x.i.orig 2003-04-17 04:20:41.000000000 -0400
++++ C64_x.i 2003-04-17 04:21:03.000000000 -0400
+@@ -100,7 +100,7 @@
+ gui = 0;
+ #else
+ // try to start up Tk gui.
+- gui = new CmdPipe("wish", "TkGui.tcl");
++ gui = new CmdPipe("wish", "/usr/bin/TkGui.tcl");
+ if (gui) {
+ if (gui->fail) {
+ delete gui; gui = 0;
+--- main.cpp.orig 2003-04-17 04:32:24.000000000 -0400
++++ main.cpp 2003-04-17 04:33:20.000000000 -0400
+@@ -24,10 +24,10 @@
+ #define CHAR_ROM_FILE "FrodoRsrc:Char_ROM"
+ #define FLOPPY_ROM_FILE "FrodoRsrc:1541_ROM"
+ #else
+-#define BASIC_ROM_FILE "Basic ROM"
+-#define KERNAL_ROM_FILE "Kernal ROM"
+-#define CHAR_ROM_FILE "Char ROM"
+-#define FLOPPY_ROM_FILE "1541 ROM"
++#define BASIC_ROM_FILE "/usr/share/frodo/Basic ROM"
++#define KERNAL_ROM_FILE "/usr/share/frodo/Kernal ROM"
++#define CHAR_ROM_FILE "/usr/share/frodo/Char ROM"
++#define FLOPPY_ROM_FILE "/usr/share/frodo/1541 ROM"
+ #endif
+
+
+--- Prefs.cpp.orig 2003-04-17 04:34:05.000000000 -0400
++++ Prefs.cpp 2003-04-17 04:38:07.000000000 -0400
+@@ -25,7 +25,7 @@
+
+ Prefs::Prefs()
+ {
+- NormalCycles = 63;
++ NormalCycles = 3;
+ BadLineCycles = 23;
+ CIACycles = 63;
+ FloppyCycles = 64;
+@@ -39,7 +39,7 @@
+ for (int i=0; i<4; i++)
+ DriveType[i] = DRVTYPE_DIR;
+
+- strcpy(DrivePath[0], "64prgs");
++ strcpy(DrivePath[0], "/usr/share/frodo/64prgs");
+ strcpy(DrivePath[1], "");
+ strcpy(DrivePath[2], "");
+ strcpy(DrivePath[3], "");
+--- TkGui.tcl.orig 2003-04-17 04:41:53.000000000 -0400
++++ TkGui.tcl 2003-04-17 04:42:45.000000000 -0400
+@@ -9,15 +9,15 @@
+
+ proc defaults {} {
+ global pref
+- set pref(NormalCycles) "63"
++ set pref(NormalCycles) "3"
+ set pref(BadLineCycles) "23"
+ set pref(CIACycles) "63"
+ set pref(FloppyCycles) "64"
+ set pref(SkipFrames) "4"
+ set pref(DriveType8) "DIR"
+- set pref(DrivePath8) "./64prgs"
++ set pref(DrivePath8) "~/64prgs"
+ set pref(DriveType9) "D64"
+- set pref(DrivePath9) "./disk1.d64"
++ set pref(DrivePath9) "~/disk1.d64"
+ set pref(DriveType10) "DIR"
+ set pref(DrivePath10) ""
+ set pref(DriveType11) "DIR"