summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-24 15:13:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-24 15:13:23 +0000
commitf4387012cf140050421ba3da1bf26fbca49bbe4e (patch)
tree737aa3cdf763455b0aca2204e1a66595874c5f13 /app-emulation/lxc
parentVersion bump, bug 290540 (diff)
downloadgentoo-2-f4387012cf140050421ba3da1bf26fbca49bbe4e.tar.gz
gentoo-2-f4387012cf140050421ba3da1bf26fbca49bbe4e.tar.bz2
gentoo-2-f4387012cf140050421ba3da1bf26fbca49bbe4e.zip
Version bump, improve checking of kernel features.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/ChangeLog7
-rw-r--r--app-emulation/lxc/lxc-0.6.4.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index d988f5c232e3..2a69125ae85f 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.2 2009/11/14 19:23:22 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.3 2009/11/24 15:13:23 flameeyes Exp $
+
+*lxc-0.6.4 (24 Nov 2009)
+
+ 24 Nov 2009; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.6.4.ebuild:
+ Version bump, improve checking of kernel features.
14 Nov 2009; Sven Wegener <swegener@gentoo.org> lxc-0.6.3.ebuild:
Add ~x86 keyword.
diff --git a/app-emulation/lxc/lxc-0.6.4.ebuild b/app-emulation/lxc/lxc-0.6.4.ebuild
new file mode 100644
index 000000000000..b634d03eb677
--- /dev/null
+++ b/app-emulation/lxc/lxc-0.6.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.6.4.ebuild,v 1.1 2009/11/24 15:13:23 flameeyes Exp $
+
+EAPI="2"
+
+inherit autotools eutils linux-info versionator
+
+DESCRIPTION="LinuX Containers userspace utilities"
+HOMEPAGE="http://lxc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ >=sys-kernel/linux-headers-2.6.29"
+
+CONFIG_CHECK="~CGROUPS
+ ~CGROUP_NS ~CPUSETS ~CGROUP_CPUACCT
+ ~RESOURCE_COUNTERS ~CGROUP_MEM_RES_CTLR
+ ~CGROUP_SCHED
+
+ ~NAMESPACES
+ ~IPC_NS ~USER_NS ~PID_NS
+
+ ~SECURITY_FILE_CAPABILITIES
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUP_FREEZER
+ ~UTS_NS ~NET_NS
+ ~VETH ~MACVLAN"
+
+ERROR_DEVPTS_MULTIPLE_INSTANCES="CONFIG_DEVPTS_MULTIPLE_INSTANCES: needed for pts inside container"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+
+ERROR_VETH="CONFIG_VETH: needed for internal (inter-container) networking"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --bindir=/usr/sbin \
+ --docdir=/usr/share/doc/${PF} \
+ --with-config-path=/etc/lxc \
+ $(use_enable doc) \
+ $(use_enable examples) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS CONTRIBUTING MAINTAINERS \
+ NEWS TODO README doc/FAQ.txt || die "dodoc failed"
+
+ rm -r "${D}"/etc/lxc "${D}"/usr/sbin/lxc-{setcap,ls}
+
+ keepdir /etc/lxc
+
+ find "${D}" -name '*.la' -delete
+}