summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-31 12:59:23 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-31 12:59:23 +0000
commit5262d68eabe76260f08e85c7cc23fb4a5e0f75bf (patch)
tree5da2a4e5e281afebe33c3134d2f0df81bbc1b297 /app-emulation/qemu-softmmu
parentAs the current SVN version requires a newer libmtp, make the 9999 ebuild requ... (diff)
downloadgentoo-2-5262d68eabe76260f08e85c7cc23fb4a5e0f75bf.tar.gz
gentoo-2-5262d68eabe76260f08e85c7cc23fb4a5e0f75bf.tar.bz2
gentoo-2-5262d68eabe76260f08e85c7cc23fb4a5e0f75bf.zip
Fix building with sanitized headers.
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog6
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch12
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild14
3 files changed, 24 insertions, 8 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 0ef49af44c09..5b0479667320 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.29 2006/12/31 02:46:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.30 2006/12/31 12:59:23 vapier Exp $
+
+ 31 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/qemu-0.8.2-linux-headers.patch, qemu-softmmu-0.8.2-r1.ebuild:
+ Fix building with sanitized headers.
31 Dec 2006; Luca Barbato <lu_zero@gentoo.org>
qemu-softmmu-0.8.2-r1.ebuild:
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch
new file mode 100644
index 000000000000..6307f6b32591
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/qemu-0.8.2-linux-headers.patch
@@ -0,0 +1,12 @@
+don't actually need linux/compiler.h and sanitized headers dont include it
+
+--- qemu-0.8.2/usb-linux.c
++++ qemu-0.8.2/usb-linux.c
+@@ -26,7 +26,6 @@
+ #if defined(__linux__)
+ #include <dirent.h>
+ #include <sys/ioctl.h>
+-#include <linux/compiler.h>
+ #include <linux/usbdevice_fs.h>
+ #include <linux/version.h>
+
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
index 04dc1a391d30..0cc518859ca8 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild,v 1.4 2006/12/31 02:46:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild,v 1.5 2006/12/31 12:59:23 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -40,18 +40,18 @@ set_target_list() {
pkg_setup() {
if [ "$(gcc-major-version)" == "4" ]; then
- eerror "qemu requires gcc-3 in order to build and work correctly"
- eerror "please compile it with gcc-3"
- die "gcc 4 cannot build qemu"
+ eerror "qemu requires gcc-3 in order to build and work correctly"
+ eerror "please compile it with gcc-3"
+ die "gcc 4 cannot build qemu"
fi
}
#RUNTIME_PATH="/emul/gnemul/"
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch "${FILESDIR}/qemu-${PV}-sparc-fp.patch"
+ cd "${S}"
+ epatch "${FILESDIR}"/qemu-${PV}-linux-headers.patch
+ epatch "${FILESDIR}"/qemu-${PV}-sparc-fp.patch
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile