summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-08-01 09:46:33 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-08-01 09:46:33 +0000
commitfdc6c34ed3f39545a2519c781edc462d4659dbd9 (patch)
tree1d19782ac7cff301ab213bffa12334b65de279b2 /app-emulation/qemu-softmmu
parentNew release (diff)
downloadgentoo-2-fdc6c34ed3f39545a2519c781edc462d4659dbd9.tar.gz
gentoo-2-fdc6c34ed3f39545a2519c781edc462d4659dbd9.tar.bz2
gentoo-2-fdc6c34ed3f39545a2519c781edc462d4659dbd9.zip
New version
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog8
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.26
-rw-r--r--app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch18
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.8.2.ebuild95
4 files changed, 126 insertions, 1 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 9ac351442f52..e6abe643dcf4 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.21 2006/07/12 10:40:36 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.22 2006/08/01 09:46:33 lu_zero Exp $
+
+*qemu-softmmu-0.8.2 (01 Aug 2006)
+
+ 01 Aug 2006; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.8.2-sparc-fp.patch, +qemu-softmmu-0.8.2.ebuild:
+ New version, should work better with gcc-4
*qemu-softmmu-0.8.1-r1 (12 Jul 2006)
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.2 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.2
new file mode 100644
index 000000000000..e882cdf637e4
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.8.2
@@ -0,0 +1,6 @@
+MD5 02cfdecda90458d6393781496ec6b48b kqemu-0.7.2.tar.gz 79314
+RMD160 cdb154d51eb616d6ad9924da0175276a655edba7 kqemu-0.7.2.tar.gz 79314
+SHA256 4158b2c67603f5256a78d0065d715bde068a457aa58bbfef12dda20fe7f7ad8b kqemu-0.7.2.tar.gz 79314
+MD5 5b3a89eb2f256a8a6f3bb07f7b3f1b07 qemu-0.8.2.tar.gz 1810909
+RMD160 715c24997330352aa675cd7279731cec251f833a qemu-0.8.2.tar.gz 1810909
+SHA256 2a20d811296c859d678bdd002222aa7ca7951a641327234f3af144e822d078f3 qemu-0.8.2.tar.gz 1810909
diff --git a/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch b/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch
new file mode 100644
index 000000000000..f190f66d4ec5
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/qemu-0.8.2-sparc-fp.patch
@@ -0,0 +1,18 @@
+diff -urN qemu-0.8.2.old/target-sparc/op_helper.c qemu-0.8.2/target-sparc/op_helper.c
+--- qemu-0.8.2.old/target-sparc/op_helper.c 2006-07-22 19:23:34.000000000 +0200
++++ qemu-0.8.2/target-sparc/op_helper.c 2006-08-01 09:46:34.000000000 +0200
+@@ -12,12 +12,12 @@
+ #ifdef USE_INT_TO_FLOAT_HELPERS
+ void do_fitos(void)
+ {
+- FT0 = int32_to_float32(*((int32_t *)&FT1));
++ FT0 = int32_to_float32(*((int32_t *)&FT1), &env->fp_status);
+ }
+
+ void do_fitod(void)
+ {
+- DT0 = int32_to_float64(*((int32_t *)&FT1));
++ DT0 = int32_to_float64(*((int32_t *)&FT1), &env->fp_status);
+ }
+ #endif
+
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2.ebuild
new file mode 100644
index 000000000000..606d877d1420
--- /dev/null
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2.ebuild,v 1.1 2006/08/01 09:46:33 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="${HOMEPAGE}${P/-softmmu/}.tar.gz
+ kqemu? ( ${HOMEPAGE}kqemu-0.7.2.tar.gz )"
+
+LICENSE="GPL-2 LGPL-2.1 KQEMU"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc -sparc ~x86"
+IUSE="sdl kqemu" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip test"
+
+DEPEND="virtual/libc
+ sdl? ( media-libs/libsdl )
+ !<=app-emulation/qemu-0.7.0
+ kqemu? ( app-emulation/kqemu )
+ app-text/texi2html"
+RDEPEND="sdl? ( media-libs/libsdl )"
+
+S="${WORKDIR}/${P/-softmmu/}"
+
+set_target_list() {
+ TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu arm-softmmu mips-softmmu"
+ export TARGET_LIST
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+ if use kqemu; then
+ mv ${WORKDIR}/kqemu ${S}
+ cd ${S}/kqemu
+ #Let the configure find kqemu but NOT build it
+ sed -i -e 's:$(MAKE) -C kqemu*::' ${S}/Makefile
+ fi
+
+ cd ${S}
+ epatch "${FILESDIR}/qemu-${PV}-sparc-fp.patch"
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf="--disable-gcc-check"
+ if ! use sdl ; then
+ myconf="$myconf --disable-gfx-check"
+ fi
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ $(use_enable kqemu) \
+ ${myconf} \
+ $(use_enable sdl)\
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ chmod -x ${D}/usr/share/man/*/*
+}
+
+pkg_postinst() {
+ einfo "You will need the Universal TUN/TAP driver compiled into"
+ einfo "kernel or as a module to use the virtual network device."
+}