summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2014-11-08 18:00:44 +0000
committerMatthias Maier <tamiko@gentoo.org>2014-11-08 18:00:44 +0000
commitfa90dc1c707bd603f7473f4fe63b9000b82d3689 (patch)
tree66ba86d2b387488f24b27672b4182ed9a99d3f64 /app-emulation
parentadd missing xetex dep, bug #528594 (diff)
downloadgentoo-2-fa90dc1c707bd603f7473f4fe63b9000b82d3689.tar.gz
gentoo-2-fa90dc1c707bd603f7473f4fe63b9000b82d3689.tar.bz2
gentoo-2-fa90dc1c707bd603f7473f4fe63b9000b82d3689.zip
switch to git-r3; cleanup
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog5
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild27
2 files changed, 12 insertions, 20 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 855ea11cd4c7..d29d79ced4de 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.384 2014/11/08 17:24:40 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.385 2014/11/08 18:00:44 tamiko Exp $
+
+ 08 Nov 2014; Matthias Maier <tamiko@gentoo.org> libvirt-9999.ebuild:
+ switch to git-r3; cleanup
08 Nov 2014; Matthias Maier <tamiko@gentoo.org> libvirt-9999.ebuild:
disable -Werror for live builds; minor cleanup
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 1180e825deea..7361f0fd0c8b 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.65 2014/11/08 17:24:40 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.66 2014/11/08 18:00:44 tamiko Exp $
EAPI=5
-#BACKPORTS=062ad8b2
AUTOTOOLIZE=yes
MY_P="${P/_rc/-rc}"
@@ -12,16 +11,13 @@ MY_P="${P/_rc/-rc}"
inherit eutils user autotools linux-info systemd readme.gentoo
if [[ ${PV} = *9999* ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="git://libvirt.org/libvirt.git"
- AUTOTOOLIZE=yes
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
- ftp://libvirt.org/libvirt/${MY_P}.tar.gz
- ${BACKPORTS:+
- http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+ ftp://libvirt.org/libvirt/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
S="${WORKDIR}/${P%_rc*}"
@@ -103,7 +99,7 @@ RDEPEND="sys-libs/readline
firewalld? ( net-firewall/firewalld )
)
elibc_glibc? ( || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 ) )"
-# one? ( dev-libs/xmlrpc-c )
+
DEPEND="${RDEPEND}
virtual/pkgconfig
app-text/xhtml1
@@ -116,8 +112,8 @@ including but not limited to NATed network, you can enable the
'virt-network' USE flag.\n\n
If you are using dnsmasq on your system, you will have
to configure /etc/dnsmasq.conf to enable the following settings:\n\n
- bind-interfaces\n
- interface or except-interface\n\n
+ bind-interfaces\n
+ interface or except-interface\n\n
Otherwise you might have issues with your existing DNS server."
LXC_CONFIG_CHECK="
@@ -206,12 +202,8 @@ pkg_setup() {
src_prepare() {
touch "${S}/.mailmap"
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
if [[ ${PV} = *9999* ]]; then
-
# git checkouts require bootstrapping to create the configure script.
# Additionally the submodules must be cloned to the right locations
# bug #377279
@@ -222,8 +214,7 @@ src_prepare() {
) >.git-module-status
fi
- epatch \
- "${FILESDIR}"/libvirt-1.2.9-do_not_use_sysconf.patch
+ epatch "${FILESDIR}"/libvirt-1.2.9-do_not_use_sysconf.patch
epatch_user
@@ -292,6 +283,7 @@ src_configure() {
# udev for device support details
myconf+=" $(use_with udev)"
+ myconf+=" --without-hal"
# linux capability support so we don't need privileged accounts
myconf+=" $(use_with caps capng)"
@@ -327,9 +319,6 @@ src_configure() {
## stuff we don't yet support
myconf+=" --without-netcf"
- # we use udev over hal
- myconf+=" --without-hal"
-
# locking support
myconf+=" --without-sanlock"