summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-18 17:33:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-18 17:33:33 +0000
commit9bcdc3a581ad6a483789bb139db8f042d609fb69 (patch)
tree1ee363b999ef94932161ac84b453581a22d6adf9 /app-i18n/man-pages-de
parentbring back sysconf option. Add systemd unit file (diff)
downloadgentoo-2-9bcdc3a581ad6a483789bb139db8f042d609fb69.tar.gz
gentoo-2-9bcdc3a581ad6a483789bb139db8f042d609fb69.tar.bz2
gentoo-2-9bcdc3a581ad6a483789bb139db8f042d609fb69.zip
Version bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-i18n/man-pages-de')
-rw-r--r--app-i18n/man-pages-de/ChangeLog11
-rw-r--r--app-i18n/man-pages-de/files/man-pages-de-1.3-bzip2.patch19
-rw-r--r--app-i18n/man-pages-de/man-pages-de-1.3.ebuild50
3 files changed, 77 insertions, 3 deletions
diff --git a/app-i18n/man-pages-de/ChangeLog b/app-i18n/man-pages-de/ChangeLog
index 8450edf053d6..9bdb75595567 100644
--- a/app-i18n/man-pages-de/ChangeLog
+++ b/app-i18n/man-pages-de/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/man-pages-de
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/ChangeLog,v 1.23 2012/09/29 13:09:16 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/ChangeLog,v 1.24 2013/08/18 17:33:33 mrueg Exp $
+
+*man-pages-de-1.3 (18 Aug 2013)
+
+ 18 Aug 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/man-pages-de-1.3-bzip2.patch, +man-pages-de-1.3.ebuild:
+ Version bump
29 Sep 2012; Ulrich Müller <ulm@gentoo.org> man-pages-de-0.8.ebuild,
man-pages-de-0.12.ebuild:
@@ -109,4 +115,3 @@
25 July 2002; Sascha Schwabbauer <cybersystem@gentoo.org> ChangeLog, manpages-de-0.4.ebuild, files/digest-manpages-de-0.4 :
Initial version in Portage now..
-
diff --git a/app-i18n/man-pages-de/files/man-pages-de-1.3-bzip2.patch b/app-i18n/man-pages-de/files/man-pages-de-1.3-bzip2.patch
new file mode 100644
index 000000000000..f39472ac6e59
--- /dev/null
+++ b/app-i18n/man-pages-de/files/man-pages-de-1.3-bzip2.patch
@@ -0,0 +1,19 @@
+--- po/generate-manpage.sh.old 2012-11-29 13:26:30.000000000 +0100
++++ po/generate-manpage.sh 2013-08-18 18:34:37.715547485 +0200
+@@ -38,6 +38,16 @@
+ original="$uncompressed_manpage"
+ fi
+ fi
++# Try a bzip'ed version
++if [ ! -f "$original" ]; then
++ original=/usr/share/man/man$section/$manpage.bz2
++ if [ -f "$original" ]; then
++ # The manpage exists, but needs to be decompressed
++ uncompressed_manpage=`mktemp`
++ bzip2 -d -c "$original" > "$uncompressed_manpage"
++ original="$uncompressed_manpage"
++ fi
++fi
+ # Cannot generate manpage if the original could not be found
+ if [ ! -f "$original" ]; then
+ echo "The original manpage for $manpage could not be found." >&2
diff --git a/app-i18n/man-pages-de/man-pages-de-1.3.ebuild b/app-i18n/man-pages-de/man-pages-de-1.3.ebuild
new file mode 100644
index 000000000000..068268820fc4
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-de/man-pages-de-1.3.ebuild,v 1.1 2013/08/18 17:33:33 mrueg Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_P="${PN/-/}-${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="http://alioth.debian.org/projects/manpages-de/"
+SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="${RDEPEND}
+ app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bzip2.patch
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES README
+}