summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-07-21 15:10:29 +0000
committerMichael Weber <xmw@gentoo.org>2014-07-21 15:10:29 +0000
commita1c8b84781b150044cc19c31a94ec94c2be7d1cd (patch)
tree86a83454190d3597eada3043b9d6974b36e1c768 /app-laptop
parentStable on alpha, bug #513430 (diff)
downloadgentoo-2-a1c8b84781b150044cc19c31a94ec94c2be7d1cd.tar.gz
gentoo-2-a1c8b84781b150044cc19c31a94ec94c2be7d1cd.tar.bz2
gentoo-2-a1c8b84781b150044cc19c31a94ec94c2be7d1cd.zip
Version bump (bug 517556, thanks Sasha Medvedev)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/ChangeLog9
-rw-r--r--app-laptop/thinkfan/thinkfan-0.9.2.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-laptop/thinkfan/ChangeLog b/app-laptop/thinkfan/ChangeLog
index ae7c90e2e07c..301c3fc8a564 100644
--- a/app-laptop/thinkfan/ChangeLog
+++ b/app-laptop/thinkfan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkfan
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.17 2013/08/18 13:45:19 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.18 2014/07/21 15:10:29 xmw Exp $
+
+*thinkfan-0.9.2 (21 Jul 2014)
+
+ 21 Jul 2014; Michael Weber <xmw@gentoo.org> +thinkfan-0.9.2.ebuild:
+ Version bump (bug 517556, thanks Sasha Medvedev)
18 Aug 2013; Agostino Sarubbo <ago@gentoo.org> thinkfan-0.9_beta2.ebuild:
Stable for x86, wrt bug #480046
diff --git a/app-laptop/thinkfan/thinkfan-0.9.2.ebuild b/app-laptop/thinkfan/thinkfan-0.9.2.ebuild
new file mode 100644
index 000000000000..9c97a4b9b844
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/thinkfan-0.9.2.ebuild,v 1.1 2014/07/21 15:10:29 xmw Exp $
+
+EAPI=5
+
+inherit cmake-utils readme.gentoo systemd
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e "s:share/doc/${PN}:share/doc/${P}:" \
+ -i CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs+=(
+ "-DCMAKE_BUILD_TYPE:STRING=Debug"
+ "$(cmake-utils_use_use atasmart ATASMART)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd rcscripts/${PN}.gentoo ${PN}
+ systemd_dounit rcscripts/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."