summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Cunha <tcunha@gentoo.org>2008-11-18 00:41:57 +0000
committerTiago Cunha <tcunha@gentoo.org>2008-11-18 00:41:57 +0000
commitf61dd881b400cf34b177aa9b1c42a49b5adfd7b1 (patch)
tree52d3764a249cefac7bcf38cb5daf67b5e7569ce4 /app-misc/tmux
parentDisable MONOTONIC_SYSCALL by default since worrying about time changes on the... (diff)
downloadgentoo-2-f61dd881b400cf34b177aa9b1c42a49b5adfd7b1.tar.gz
gentoo-2-f61dd881b400cf34b177aa9b1c42a49b5adfd7b1.tar.bz2
gentoo-2-f61dd881b400cf34b177aa9b1c42a49b5adfd7b1.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-0.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 66deac56c8bb..66cdb9317d0e 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.4 2008/11/09 21:53:27 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.5 2008/11/18 00:41:57 tcunha Exp $
+
+*tmux-0.5 (18 Nov 2008)
+
+ 18 Nov 2008; Tiago Cunha <tcunha@gentoo.org> +tmux-0.5.ebuild:
+ Version bump
09 Nov 2008; Tiago Cunha <tcunha@gentoo.org> metadata.xml:
I'll be maintaining this now. Thanks swegener
diff --git a/app-misc/tmux/tmux-0.5.ebuild b/app-misc/tmux/tmux-0.5.ebuild
new file mode 100644
index 000000000000..e76a7540a403
--- /dev/null
+++ b/app-misc/tmux/tmux-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-0.5.ebuild,v 1.1 2008/11/18 00:41:57 tcunha Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEBUG="" || die "emake failed"
+}
+
+src_install() {
+ dobin tmux || die "dobin failed"
+
+ dodoc NOTES TODO || die "dodoc failed"
+ docinto examples
+ dodoc examples/*.conf || die "dodoc examples failed"
+
+ doman tmux.1 || die "doman failed"
+}