summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-05-08 18:31:28 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-05-08 18:31:28 +0000
commit7d9a1be721b3eb11bb400a9fc79b9c88d8893deb (patch)
tree255750c2b5fedbe5f52c0aa186731ec805ad2ef5 /app-shells/push
parentStable on amd64 wrt bug #414241 (diff)
downloadgentoo-2-7d9a1be721b3eb11bb400a9fc79b9c88d8893deb.tar.gz
gentoo-2-7d9a1be721b3eb11bb400a9fc79b9c88d8893deb.tar.bz2
gentoo-2-7d9a1be721b3eb11bb400a9fc79b9c88d8893deb.zip
New ebuild by Martin Väth
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/push')
-rw-r--r--app-shells/push/ChangeLog10
-rw-r--r--app-shells/push/Manifest4
-rw-r--r--app-shells/push/metadata.xml21
-rw-r--r--app-shells/push/push-1.5.ebuild21
4 files changed, 56 insertions, 0 deletions
diff --git a/app-shells/push/ChangeLog b/app-shells/push/ChangeLog
new file mode 100644
index 000000000000..a4297acb397a
--- /dev/null
+++ b/app-shells/push/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/push
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/push/ChangeLog,v 1.1 2012/05/08 18:31:28 darkside Exp $
+
+*push-1.5 (08 May 2012)
+
+ 08 May 2012; Jeremy Olexa <darkside@gentoo.org> +push-1.5.ebuild,
+ +metadata.xml:
+ New ebuild by Martin Väth
+
diff --git a/app-shells/push/Manifest b/app-shells/push/Manifest
new file mode 100644
index 000000000000..4a0fee6c062d
--- /dev/null
+++ b/app-shells/push/Manifest
@@ -0,0 +1,4 @@
+DIST push-1.5.tar.gz 1971 RMD160 262ae766077ab2e290a43256d390ce48731655ba SHA1 90bcf19e8870c4b38dcaf5c1f6f36d02f6b0d38a SHA256 7c9068a619bcc49e3e13f819e23e1c05464729df0529753557f23f65e922fdad
+EBUILD push-1.5.ebuild 724 RMD160 d14b0827dd58b8d3909a35b4a00640477e56d843 SHA1 02ce288a4b3758be25a97aa203c377c5152e8e58 SHA256 0155eab7348bcf584e4bf1790dadb44373116c6f7a2992f9678376dc3912248e
+MISC ChangeLog 256 RMD160 c7087575e4653ae02b9c9fcbce92d07b5d3d94b4 SHA1 a6b367f5880372f261970ff8bd02a737167bc7c2 SHA256 3d78a4d36c2145a45bc9c0f5f093261c21b0cce72d8836ecc593852bf0af7706
+MISC metadata.xml 676 RMD160 0cfe595d05b12eb92658a6bef3e4ab9534969db0 SHA1 173c9fa2be87a2fce8a998a642da4958df43c960 SHA256 8f98eee1ac053d07128e7d6d1da2cd4b2e826b87d52719d19e498d2a1f041fe0
diff --git a/app-shells/push/metadata.xml b/app-shells/push/metadata.xml
new file mode 100644
index 000000000000..63a32b512488
--- /dev/null
+++ b/app-shells/push/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vaeth@mathematik.uni-wuerzburg.de</email>
+ <name>Martin Väth</name>
+ <description>Upstream developer, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>darkside@gentoo.org</email>
+ <name>Jeremy Olexa</name>
+ <description>Proxy committer, CC bugs</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>vaeth@mathematik.uni-wuerzburg.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:vaeth@mathematik.uni-wuerzburg.de</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/push/push-1.5.ebuild b/app-shells/push/push-1.5.ebuild
new file mode 100644
index 000000000000..0fd10914e9f6
--- /dev/null
+++ b/app-shells/push/push-1.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args."
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}