summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-15 07:25:52 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-15 07:25:52 +0000
commit90f57776c7b96b6361c3dae21ed18e5f5188c003 (patch)
treeef0ac11348bfc508a8963136d1b261cea9ea90df /app-text/hunspell
parentAdd comment about hyphenation. (diff)
downloadgentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.tar.gz
gentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.tar.bz2
gentoo-2-90f57776c7b96b6361c3dae21ed18e5f5188c003.zip
Version bump, bug #314565, thank Samuli Suominen for report. Automatically pull in myspell-* dictionaries based on LINGUAS setting, bug #261050, thank Tobias Leupold for report. Hopefully fixes build on IRIX, bug #257781.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/hunspell')
-rw-r--r--app-text/hunspell/ChangeLog11
-rw-r--r--app-text/hunspell/files/hunspell-1.2.9-renameexes.patch116
-rw-r--r--app-text/hunspell/hunspell-1.2.9.ebuild77
3 files changed, 203 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index f2dcc21f478d..b70864470e15 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.63 2010/04/06 17:08:52 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.64 2010/04/15 07:25:52 pva Exp $
+
+*hunspell-1.2.9 (15 Apr 2010)
+
+ 15 Apr 2010; Peter Volkov <pva@gentoo.org> +hunspell-1.2.9.ebuild,
+ +files/hunspell-1.2.9-renameexes.patch:
+ Version bump, bug #314565, thank Samuli Suominen for report. Automatically
+ pull in myspell-* dictionaries based on LINGUAS setting, bug #261050,
+ thank Tobias Leupold for report. Hopefully fixes build on IRIX, bug
+ #257781.
06 Apr 2010; Jonathan Callen <abcd@gentoo.org> hunspell-1.2.8.ebuild:
Add prefix keywords, -liconv on Darwin
diff --git a/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch b/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch
new file mode 100644
index 000000000000..58f366c41f13
--- /dev/null
+++ b/app-text/hunspell/files/hunspell-1.2.9-renameexes.patch
@@ -0,0 +1,116 @@
+=== modified file 'src/tools/Makefile.am'
+--- src/tools/Makefile.am 2010-04-15 06:56:50 +0000
++++ src/tools/Makefile.am 2010-04-15 06:59:21 +0000
+@@ -1,4 +1,5 @@
+ bin_PROGRAMS=analyze chmorph hunspell munch unmunch hzip hunzip
++bin_PROGRAMS=hunspell-analyze hunspell-chmorph hunspell hunspell-munch hunspell-unmunch hzip hunzip
+
+ INCLUDES=-I${top_srcdir}/src/hunspell -I${top_srcdir}/src/parsers
+
+@@ -6,8 +7,8 @@
+ hunzip_SOURCES=hunzip.cxx
+ hunzip_LDADD = ../hunspell/libhunspell-1.2.la
+
+-munch_SOURCES=munch.c munch.h
+-unmunch_SOURCES=unmunch.c unmunch.h
++hunspell_munch_SOURCES=munch.c munch.h
++hunspell_unmunch_SOURCES=unmunch.c unmunch.h
+
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.2.la
+@@ -16,11 +17,11 @@
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../hunspell/libhunspell-1.2.la \
+ ../parsers/libparsers.a @CURSESLIB@ @READLINELIB@
+
+-analyze_SOURCES=analyze.cxx
+-analyze_LDADD = ../hunspell/libhunspell-1.2.la
++hunspell_analyze_SOURCES=analyze.cxx
++hunspell_analyze_LDADD = ../hunspell/libhunspell-1.2.la
+
+-chmorph_SOURCES=chmorph.cxx
+-chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
++hunspell_chmorph_SOURCES=chmorph.cxx
++hunspell_chmorph_LDADD = ../hunspell/libhunspell-1.2.la ../parsers/libparsers.a
+
+ noinst_PROGRAMS=example
+
+
+=== modified file 'src/tools/example.cxx'
+--- src/tools/example.cxx 2010-04-15 06:56:50 +0000
++++ src/tools/example.cxx 2010-04-15 06:57:34 +0000
+@@ -17,8 +17,8 @@
+ /* first parse the command line options */
+
+ if (argc < 4) {
+- fprintf(stderr,"example (now it works with more dictionary files):\n");
+- fprintf(stderr,"example affix_file dictionary_file(s) file_of_words_to_check\n");
++ fprintf(stderr,"hunspell-example (now it works with more dictionary files):\n");
++ fprintf(stderr,"hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/munch.c'
+--- src/tools/munch.c 2010-04-15 06:56:50 +0000
++++ src/tools/munch.c 2010-04-15 06:57:34 +0000
+@@ -42,14 +42,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"munch word_list_file affix_file\n");
++ fprintf(stderr,"hunspell-munch word_list_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'src/tools/unmunch.c'
+--- src/tools/unmunch.c 2010-04-15 06:56:50 +0000
++++ src/tools/unmunch.c 2010-04-15 06:57:34 +0000
+@@ -39,14 +39,14 @@
+ wf = mystrdup(argv[1]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+ if (argv[2]) {
+ af = mystrdup(argv[2]);
+ } else {
+ fprintf(stderr,"correct syntax is:\n");
+- fprintf(stderr,"unmunch dic_file affix_file\n");
++ fprintf(stderr,"hunspell-unmunch dic_file affix_file\n");
+ exit(1);
+ }
+
+
+=== modified file 'tests/test.sh'
+--- tests/test.sh 2010-04-15 06:56:50 +0000
++++ tests/test.sh 2010-04-15 07:00:31 +0000
+@@ -34,7 +34,7 @@
+ shopt -s expand_aliases
+
+ alias hunspell='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell'
+-alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/analyze'
++alias analyze='../libtool --mode=execute -dlopen ../src/hunspell/.libs/libhunspell*.la ../src/tools/hunspell-analyze'
+
+ if [ "$VALGRIND" != "" ]; then
+ rm -f $TEMPDIR/test.pid*
+@@ -42,7 +42,7 @@
+ mkdir $TEMPDIR/badlogs
+ fi
+ alias hunspell='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell'
+- alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-analyze'
++ alias analyze='valgrind --tool=$VALGRIND --leak-check=yes --show-reachable=yes --log-file=$TEMPDIR/test.pid ../src/tools/.libs/lt-hunspell-analyze'
+ fi
+
+ # Tests good words
+
diff --git a/app-text/hunspell/hunspell-1.2.9.ebuild b/app-text/hunspell/hunspell-1.2.9.ebuild
new file mode 100644
index 000000000000..f3dda33c175c
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.2.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.2.9.ebuild,v 1.1 2010/04/15 07:25:52 pva Exp $
+
+EAPI="2"
+inherit eutils multilib autotools flag-o-matic
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo."
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+#TODO: "ia" "mi" - check what they are and add appropriate desc...
+def="app-dicts/myspell-en"
+for l in \
+"af" "bg" "ca" "cs" "cy" "da" "de" "el" "en" "eo" "es" "et" "fo" "fr" "ga" \
+"gl" "he" "hr" "hu" "id" "it" "ku" "lt" "lv" "mk" "ms" "nb" "nl" \
+"nn" "pl" "pt" "ro" "ru" "sk" "sl" "sv" "sw" "tn" "uk" "zu" \
+; do
+ dep="linguas_${l}? ( app-dicts/myspell-${l/pt_BR/pt-br} )"
+ [[ ${l} = "de" ]] &&
+ dep="linguas_de? ( || ( app-dicts/myspell-de app-dicts/myspell-de-alt ) )"
+ [[ -z ${PDEPEND} ]] &&
+ PDEPEND="${dep}" ||
+ PDEPEND="${PDEPEND}
+${dep}"
+ def="!linguas_${l}? ( ${def} )"
+ IUSE="${IUSE} linguas_${l}"
+done
+PDEPEND="${PDEPEND}
+${def}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ epatch "${FILESDIR}"/${PN}-1.2.9-renameexes.patch
+ eautoreconf
+}
+
+src_configure() {
+ # missing somehow, and I am too lazy to fix it properly
+ [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
+
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ $(use_enable nls) \
+ $(use_with ncurses ui) \
+ $(use_with readline readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell || die "installing docs failed"
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell || die "installing myspell docs failed"
+}
+
+pkg_postinst() {
+ elog "To use this package you will also need a dictionary."
+ elog "Hunspell uses myspell format dictionaries; find them"
+ elog "in the app-dicts category as myspell-<LANG>."
+}