summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2007-12-18 21:13:36 +0000
committerJeroen Roovers <jer@gentoo.org>2007-12-18 21:13:36 +0000
commitd157544a321c9d954ed75b65b78555a6875d97d6 (patch)
tree424cb5cdb8b4547f0289ca8022802e06317722da /app-text/noweb
parentMarked ~hppa (bug #195815). (diff)
downloadgentoo-2-d157544a321c9d954ed75b65b78555a6875d97d6.tar.gz
gentoo-2-d157544a321c9d954ed75b65b78555a6875d97d6.tar.bz2
gentoo-2-d157544a321c9d954ed75b65b78555a6875d97d6.zip
Marked ~hppa (bug #195815).
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-text/noweb')
-rw-r--r--app-text/noweb/ChangeLog5
-rw-r--r--app-text/noweb/noweb-2.9-r6.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/app-text/noweb/ChangeLog b/app-text/noweb/ChangeLog
index 55890bdbb674..dfaf8a752c49 100644
--- a/app-text/noweb/ChangeLog
+++ b/app-text/noweb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/noweb
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.24 2007/10/26 20:18:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.25 2007/12/18 21:13:36 jer Exp $
+
+ 18 Dec 2007; Jeroen Roovers <jer@gentoo.org> noweb-2.9-r6.ebuild:
+ Marked ~hppa (bug #195815).
26 Oct 2007; Raúl Porcel <armin76@gentoo.org> noweb-2.9-r6.ebuild:
Add ~ia64
diff --git a/app-text/noweb/noweb-2.9-r6.ebuild b/app-text/noweb/noweb-2.9-r6.ebuild
index de0e05147061..7fb400985fc4 100644
--- a/app-text/noweb/noweb-2.9-r6.ebuild
+++ b/app-text/noweb/noweb-2.9-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r6.ebuild,v 1.3 2007/10/26 20:18:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r6.ebuild,v 1.4 2007/12/18 21:13:36 jer Exp $
inherit eutils
@@ -13,7 +13,7 @@ DESCRIPTION="a literate programming tool, lighter than web"
SLOT="0"
IUSE="icon"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86" # will test ppc later
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86" # will test ppc later
DEPEND="sys-devel/gcc
virtual/tetex
@@ -23,10 +23,10 @@ DEPEND="sys-devel/gcc
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A} ; cd "${S}"
- epatch ${FILESDIR}/${P}-security.patch
- epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-security.patch
+ epatch "${FILESDIR}"/${P}-gentoo.diff
# make touch only touches the files required, not the whole
# tree as with find . -type f | xargs touch <obz@gentoo.org>
@@ -41,7 +41,7 @@ src_compile() {
# noweb tries to use notangle and noweb; see bug #50429
( cd c; emake CFLAGS="${CFLAGS}" LIBSRC="$libsrc" ) || die
export PATH="${PATH}:${T}"
- emake BIN=${T} LIB=${T} LIBSRC="$libsrc" install-code \
+ emake BIN="${T}" LIB="${T}" LIBSRC="$libsrc" install-code \
|| die "make temporal install failed."
emake CFLAGS="${CFLAGS}" LIBSRC="$libsrc" || die
@@ -50,11 +50,11 @@ src_compile() {
src_install () {
local libsrc
use icon && libsrc="icon" || libsrc="awk"
- make DESTDIR=${D} LIBSRC="$libsrc" install || die
+ make DESTDIR="${D}" LIBSRC="$libsrc" install || die
use icon || [ -x /usr/bin/nawk ] || dosym /usr/bin/gawk /usr/bin/nawk
# fix man pages to be LFH compliant
- mv ${D}/usr/man ${D}/usr/share
+ mv "${D}"/usr/man "${D}"/usr/share
}
pkg_postinst() {