summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-10 18:29:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-10 18:29:35 +0000
commited556ff8b67685248dae49b6d91132ddb3dfb35a (patch)
tree095629d8ada77a372831d64177dfac2b27a05388 /app-text/noweb
parentppc stable, bug #209106 (diff)
downloadgentoo-2-ed556ff8b67685248dae49b6d91132ddb3dfb35a.tar.gz
gentoo-2-ed556ff8b67685248dae49b6d91132ddb3dfb35a.tar.bz2
gentoo-2-ed556ff8b67685248dae49b6d91132ddb3dfb35a.zip
version bump, bug #149688
(Portage version: 2.1.4.2)
Diffstat (limited to 'app-text/noweb')
-rw-r--r--app-text/noweb/ChangeLog9
-rw-r--r--app-text/noweb/noweb-2.11b.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/app-text/noweb/ChangeLog b/app-text/noweb/ChangeLog
index dfaf8a752c49..f50f9ac8c8d6 100644
--- a/app-text/noweb/ChangeLog
+++ b/app-text/noweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/noweb
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.25 2007/12/18 21:13:36 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.26 2008/02/10 18:29:35 aballier Exp $
+
+*noweb-2.11b (10 Feb 2008)
+
+ 10 Feb 2008; Alexis Ballier <aballier@gentoo.org> +noweb-2.11b.ebuild:
+ version bump, bug #149688
18 Dec 2007; Jeroen Roovers <jer@gentoo.org> noweb-2.9-r6.ebuild:
Marked ~hppa (bug #195815).
diff --git a/app-text/noweb/noweb-2.11b.ebuild b/app-text/noweb/noweb-2.11b.ebuild
new file mode 100644
index 000000000000..b7cacccbb0ec
--- /dev/null
+++ b/app-text/noweb/noweb-2.11b.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.11b.ebuild,v 1.1 2008/02/10 18:29:35 aballier Exp $
+
+inherit eutils toolchain-funcs
+
+SRC_URI="http://www.eecs.harvard.edu/~nr/noweb/dist/${P}.tgz"
+HOMEPAGE="http://www.eecs.harvard.edu/~nr/noweb/"
+LICENSE="freedist"
+DESCRIPTION="a literate programming tool, lighter than web"
+
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86" # will test ppc later
+
+DEPEND="virtual/tex-base
+ dev-lang/icon
+ sys-apps/debianutils"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.9-security.patch
+ # dont run texhash...
+ sed -i -e "s/texhash/true/" Makefile
+ # dont strip...
+ sed -i -e "s/strip/true/" Makefile
+}
+
+src_compile() {
+ # noweb tries to use notangle and noweb; see bug #50429
+ ( cd c; emake ICONC="icont" CC=$(tc-getCC) CFLAGS="${CFLAGS}" LIBSRC="icon" ) || die
+ export PATH="${PATH}:${T}"
+ emake ICONC="icont" CC=$(tc-getCC) BIN="${T}" LIB="${T}" LIBSRC="icon" install-code \
+ || die "make temporal install failed."
+
+ emake ICONC="icont" CC=$(tc-getCC) CFLAGS="${CFLAGS}" LIBSRC="icon" || die "make failed"
+ # Set awk to awk not nawk
+ ./awkname awk
+}
+
+src_install () {
+ # It needs the directories to exisst first...
+ dodir /usr/bin
+ dodir /usr/libexec/${PN}
+ dodir /usr/share/man
+ dodir /usr/share/texmf/tex/inputs
+ emake ICONC="icont" \
+ BIN="${D}/usr/bin" \
+ LIBSRC="icon" \
+ LIBNAME="/usr/libexec/${PN}" \
+ LIB="${D}/usr/libexec/${PN}" \
+ MAN="${D}/usr/share/man" \
+ TEXNAME="/usr/share/texmf/tex/inputs" \
+ TEXINPUTS="${D}/usr/share/texmf/tex/inputs" \
+ install || die "make install failed"
+ cd "${WORKDIR}/${P}"
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ dodoc CHANGES README
+}
+
+pkg_postinst() {
+ einfo "Running texhash to complete installation.."
+ texhash
+}