summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-02-12 21:54:15 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-02-12 21:54:15 +0000
commit5baf5648984bfca16a28917c379f9f771df2186a (patch)
tree13aa9472c7ecc145159ec27b30c50f7d63ce8056 /dev-cpp/gflags
parentalpha/ia64/s390/sh/sparc stable wrt #344827 (diff)
downloadgentoo-2-5baf5648984bfca16a28917c379f9f771df2186a.tar.gz
gentoo-2-5baf5648984bfca16a28917c379f9f771df2186a.tar.bz2
gentoo-2-5baf5648984bfca16a28917c379f9f771df2186a.zip
Version bump.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gflags')
-rw-r--r--dev-cpp/gflags/ChangeLog10
-rw-r--r--dev-cpp/gflags/gflags-1.2.ebuild57
-rw-r--r--dev-cpp/gflags/gflags-1.5.ebuild28
3 files changed, 36 insertions, 59 deletions
diff --git a/dev-cpp/gflags/ChangeLog b/dev-cpp/gflags/ChangeLog
index a951a7d42054..6afa9ee6d831 100644
--- a/dev-cpp/gflags/ChangeLog
+++ b/dev-cpp/gflags/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/gflags
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.11 2010/11/08 11:22:54 nelchael Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.12 2011/02/12 21:54:14 nelchael Exp $
+
+*gflags-1.5 (12 Feb 2011)
+
+ 12 Feb 2011; Krzysztof Pawlik <nelchael@gentoo.org> -gflags-1.2.ebuild,
+ +gflags-1.5.ebuild:
+ Version bump.
08 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org> metadata.xml:
Improve metadata: add no-herd and my name.
diff --git a/dev-cpp/gflags/gflags-1.2.ebuild b/dev-cpp/gflags/gflags-1.2.ebuild
deleted file mode 100644
index ebd26fe4f380..000000000000
--- a/dev-cpp/gflags/gflags-1.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-1.2.ebuild,v 1.2 2010/05/29 20:50:21 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Google's C++ argument parsing library with python extensions."
-HOMEPAGE="http://code.google.com/p/google-gflags/"
-SRC_URI="http://google-gflags.googlecode.com/files/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="python"
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-PYTHON_MODNAME="gflags.py"
-
-src_compile() {
- default
-
- if use python; then
- cd python
- distutils_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- rm -rf "${D}"/usr/share/doc/*
- AUTHORS ChangeLog NEWS README
- dohtml doc/*
-
- if use python; then
- cd python
- distutils_src_install
- fi
-}
-
-pkg_postinst() {
- if use python; then
- distutils_pkg_postinst
- fi
-}
-
-pkg_postrm() {
- if use python; then
- distutils_pkg_postrm
- fi
-}
diff --git a/dev-cpp/gflags/gflags-1.5.ebuild b/dev-cpp/gflags/gflags-1.5.ebuild
new file mode 100644
index 000000000000..511b753db3ad
--- /dev/null
+++ b/dev-cpp/gflags/gflags-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-1.5.ebuild,v 1.1 2011/02/12 21:54:14 nelchael Exp $
+
+EAPI="3"
+
+DESCRIPTION="Google's C++ argument parsing library."
+HOMEPAGE="http://code.google.com/p/google-gflags/"
+SRC_URI="http://google-gflags.googlecode.com/files/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/*
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*
+}