summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-03-07 14:13:14 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-03-07 14:13:14 +0000
commit886086f32557facd27207edef9aebf2dbb397232 (patch)
tree13577d62c3aa8e8fe10097b43b73decbe7e551d2 /dev-db/oracle-instantclient-sqlplus
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-886086f32557facd27207edef9aebf2dbb397232.tar.gz
gentoo-2-886086f32557facd27207edef9aebf2dbb397232.tar.bz2
gentoo-2-886086f32557facd27207edef9aebf2dbb397232.zip
Revbump. Use EAPI 4. Update homepage. Drop useless postinst info.
RDEPEND on _same_ version of oracle-instantclient-basic. (Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/oracle-instantclient-sqlplus')
-rw-r--r--dev-db/oracle-instantclient-sqlplus/ChangeLog9
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild65
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-sqlplus/ChangeLog b/dev-db/oracle-instantclient-sqlplus/ChangeLog
index 70756d04d9c5..137e95bd89a1 100644
--- a/dev-db/oracle-instantclient-sqlplus/ChangeLog
+++ b/dev-db/oracle-instantclient-sqlplus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/oracle-instantclient-sqlplus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.30 2012/02/09 14:26:45 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.31 2012/03/07 14:13:14 haubi Exp $
+
+*oracle-instantclient-sqlplus-11.2.0.3 (07 Mar 2012)
+
+ 07 Mar 2012; Michael Haubenwallner <haubi@gentoo.org>
+ +oracle-instantclient-sqlplus-11.2.0.3.ebuild:
+ Revbump. Use EAPI 4. Update homepage. Drop useless postinst info.
+ RDEPEND on _same_ version of oracle-instantclient-basic.
09 Feb 2012; Michael Haubenwallner <haubi@gentoo.org> metadata.xml:
Taking over maintainership.
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild
new file mode 100644
index 000000000000..d2a6e470b3c9
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild,v 1.1 2012/03/07 14:13:14 haubi Exp $
+
+EAPI="4"
+
+inherit eutils
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN#oracle-}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN#oracle-}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: SQL*Plus"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+ x86? ( ${MY_A_x86} )
+ amd64? ( ${MY_A_amd64} )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"/instantclient_11_2
+
+my_arch() {
+ # platform name
+ MY_PLAT=MY_PLAT_${ARCH}
+ export MY_PLAT=${!MY_PLAT}
+ # distfile
+ MY_A=MY_A_${ARCH}
+ export MY_A=${!MY_A}
+}
+
+pkg_nofetch() {
+ my_arch
+ eerror "Please go to"
+ eerror " ${HOMEPAGE%/*}/index-097480.html"
+ eerror " and download"
+ eerror "Instant Client for ${MY_PLAT}"
+ eerror " SQL*Plus: ${MY_A}"
+ eerror "After downloading, put it in:"
+ eerror " ${DISTDIR}/"
+}
+
+src_install() {
+ # all binaries go here
+ local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
+ into "${oracle_home}"
+
+ dolib.so libsqlplus$(get_libname) libsqlplusic$(get_libname)
+ dobin sqlplus
+
+ insinto "${oracle_home}"/sqlplus/admin
+ doins glogin.sql
+
+ dosym "${oracle_home}"/bin/sqlplus /usr/bin/sqlplus
+}