summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-02 18:18:19 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-02 18:18:19 +0000
commitcdd0dbc959e96c2de74e226906b0fde420448e4f (patch)
tree33ede925d4e25f692f667fc3fdcef35db733aa70 /dev-db
parentKeyworded ~sparc wrt #164778 (diff)
downloadgentoo-2-cdd0dbc959e96c2de74e226906b0fde420448e4f.tar.gz
gentoo-2-cdd0dbc959e96c2de74e226906b0fde420448e4f.tar.bz2
gentoo-2-cdd0dbc959e96c2de74e226906b0fde420448e4f.zip
Version bump. Fixes bug #157214 and bug #159197.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.3.123
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild95
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index abe11e5ebc2c..dbc72e0fe35c 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.133 2007/01/31 13:54:33 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.134 2007/02/02 18:18:19 betelgeuse Exp $
+
+*sqlite-3.3.12 (02 Feb 2007)
+
+ 02 Feb 2007; Petteri Räty <betelgeuse@gentoo.org> +sqlite-3.3.12.ebuild:
+ Version bump. Fixes bug #157214 and bug #159197.
31 Jan 2007; Marius Mauch <genone@gentoo.org> sqlite-2.8.16-r4.ebuild:
Replacing einfo with elog
diff --git a/dev-db/sqlite/files/digest-sqlite-3.3.12 b/dev-db/sqlite/files/digest-sqlite-3.3.12
new file mode 100644
index 000000000000..adc1561bebd5
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.3.12
@@ -0,0 +1,3 @@
+MD5 ae251cc7a4b54b80941d400ed5af01b7 sqlite-3.3.12.tar.gz 2021696
+RMD160 98154b3e8663b6c7ec11a7094a51781ee8384317 sqlite-3.3.12.tar.gz 2021696
+SHA256 e005781cb0356f65200c05979c04fea533b9a7d873e0060672a4d384468b7186 sqlite-3.3.12.tar.gz 2021696
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
new file mode 100644
index 000000000000..62c2de72d5e5
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.3.12.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.1 2007/02/02 18:18:19 betelgeuse Exp $
+
+inherit eutils alternatives libtool
+
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nothreadsafe doc tcl test debug"
+
+DEPEND="
+ doc? ( dev-lang/tcl )
+ tcl? ( dev-lang/tcl )
+ test? ( dev-lang/tcl )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+
+SOURCE="/usr/bin/lemon"
+ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+
+src_unpack() {
+ # test
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ ewarn "Testsuite will not be run."
+ fi
+ if ! use test; then
+ eerror "The test useflag must be enabled to run tests."
+ die "test use flag disabled"
+ fi
+ fi
+
+ unpack ${A}
+
+ cd ${P}
+ epatch ${FILESDIR}/sqlite-3.3.3-tcl-fix.patch
+ #epatch ${FILESDIR}/sqlite-3-test-fix-3.3.4.patch
+
+ epatch ${FILESDIR}/sandbox-fix2.patch
+
+ # Fix broken tests that are not portable to 64 arches
+ epatch ${FILESDIR}/sqlite-64bit-test-fix.patch
+ epatch ${FILESDIR}/sqlite-64bit-test-fix2.patch
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf="--enable-incore-db --enable-tempdb-in-ram --enable-cross-thread-connections"
+
+ econf ${myconf} \
+ $(use_enable !nothreadsafe threadsafe) \
+ $(use_enable tcl) \
+ $(use_enable debug) || die
+
+ emake all || die
+
+ if use doc; then
+ emake doc || die
+ fi
+}
+
+src_test() {
+ if use test ; then
+ if has userpriv ${FEATURES} ; then
+ cd ${S}
+ if use debug; then
+ emake fulltest || die "some test failed"
+ else
+ emake test || die "some test failed"
+ fi
+ fi
+ fi
+}
+
+src_install () {
+ make \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install || die
+
+ newbin lemon lemon-${SLOT}
+
+ dodoc README VERSION || die
+ doman sqlite3.1 || die
+
+ use doc && dohtml doc/* art/*.gif
+}