summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-04-24 16:20:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-04-24 16:20:00 +0000
commit1832780947a36e2a7a9c0cda15e434547467b6a8 (patch)
treeae5bf154aecb21b3f6d326ab1eeb8b9a37761623 /dev-games
parentFix for Prefix, keyworded ~x86-solaris, bug #296509 (diff)
downloadgentoo-2-1832780947a36e2a7a9c0cda15e434547467b6a8.tar.gz
gentoo-2-1832780947a36e2a7a9c0cda15e434547467b6a8.tar.bz2
gentoo-2-1832780947a36e2a7a9c0cda15e434547467b6a8.zip
version bump (bug #364559)
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/physfs/ChangeLog9
-rw-r--r--dev-games/physfs/physfs-2.0.2.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-games/physfs/ChangeLog b/dev-games/physfs/ChangeLog
index 583c632c737c..d38de868494b 100644
--- a/dev-games/physfs/ChangeLog
+++ b/dev-games/physfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/physfs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.37 2010/10/15 12:41:05 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.38 2011/04/24 16:20:00 mr_bones_ Exp $
+
+*physfs-2.0.2 (24 Apr 2011)
+
+ 24 Apr 2011; Michael Sterrett <mr_bones_@gentoo.org> +physfs-2.0.2.ebuild:
+ version bump (bug #364559)
15 Oct 2010; Brent Baude <ranger@gentoo.org> physfs-2.0.1.ebuild:
stable ppc, bug 317239
diff --git a/dev-games/physfs/physfs-2.0.2.ebuild b/dev-games/physfs/physfs-2.0.2.ebuild
new file mode 100644
index 000000000000..41aca920a1cf
--- /dev/null
+++ b/dev-games/physfs/physfs-2.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/physfs-2.0.2.ebuild,v 1.1 2011/04/24 16:20:00 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc grp hog mvl qpak static-libs wad +zip"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::' \
+ -e '/DESTINATION/s:lib:lib${LIB_SUFFIX}:' \
+ CMakeLists.txt \
+ || die "sed failed"
+ # make sure these libs aren't used
+ rm -rf lzma zlib*
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DPHYSFS_ARCHIVE_7Z=OFF
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_WX_TEST=OFF
+ -DPHYSFS_INTERNAL_ZLIB=OFF
+ $(cmake-utils_use static-libs PHYSFS_BUILD_STATIC)
+ $(cmake-utils_use grp PHYSFS_ARCHIVE_GRP)
+ $(cmake-utils_use hog PHYSFS_ARCHIVE_HOG)
+ $(cmake-utils_use mvl PHYSFS_ARCHIVE_MVL)
+ $(cmake-utils_use wad PHYSFS_ARCHIVE_WAD)
+ $(cmake-utils_use qpak PHYSFS_ARCHIVE_QPAK)
+ $(cmake-utils_use zip PHYSFS_ARCHIVE_ZIP)"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ local DOCS="CHANGELOG.txt CREDITS.txt TODO.txt"
+ local HTML_DOCS=$(use doc && echo docs/html/*)
+
+ cmake-utils_src_install
+}