summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-15 18:07:49 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-15 18:07:49 +0000
commited458d307458559ae18463202be61d53773db642 (patch)
tree9615a8fc1b69c2d0b41b308734487b5afae0a6a2 /dev-haskell/cpphs/cpphs-1.7.ebuild
parentadded live ebuild (diff)
downloadgentoo-2-ed458d307458559ae18463202be61d53773db642.tar.gz
gentoo-2-ed458d307458559ae18463202be61d53773db642.tar.bz2
gentoo-2-ed458d307458559ae18463202be61d53773db642.zip
Version bump dev-haskell/cpphs
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/cpphs/cpphs-1.7.ebuild')
-rw-r--r--dev-haskell/cpphs/cpphs-1.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-haskell/cpphs/cpphs-1.7.ebuild b/dev-haskell/cpphs/cpphs-1.7.ebuild
new file mode 100644
index 000000000000..1bd8396de283
--- /dev/null
+++ b/dev-haskell/cpphs/cpphs-1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpphs/cpphs-1.7.ebuild,v 1.1 2009/07/15 18:07:49 kolmodin Exp $
+
+CABAL_FEATURES="bin lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="A liberalised re-implementation of cpp, the C pre-processor."
+HOMEPAGE="http://haskell.org/cpphs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/cabal"
+RDEPEND=""
+
+src_install() {
+ cabal_src_install
+ dohtml docs/index.html
+ doman docs/cpphs.1
+}