summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-03-11 08:49:19 +0000
committerMark Wright <gienah@gentoo.org>2015-03-11 08:49:19 +0000
commit6f84b1d41378a86f0950f7b00e386193a9db8c02 (patch)
treefa974d8d3a6557022ff0485ec024c79301a1a96c /dev-haskell
parentInstall README, #542598 and fix prestripping (diff)
downloadgentoo-2-6f84b1d41378a86f0950f7b00e386193a9db8c02.tar.gz
gentoo-2-6f84b1d41378a86f0950f7b00e386193a9db8c02.tar.bz2
gentoo-2-6f84b1d41378a86f0950f7b00e386193a9db8c02.zip
Bump cairo to 0.13.1.0
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cairo/ChangeLog9
-rw-r--r--dev-haskell/cairo/cairo-0.13.1.0.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-haskell/cairo/ChangeLog b/dev-haskell/cairo/ChangeLog
index 05804bd2e31b..f752ccb35a8d 100644
--- a/dev-haskell/cairo/ChangeLog
+++ b/dev-haskell/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cairo
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/ChangeLog,v 1.33 2014/12/13 13:29:33 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/ChangeLog,v 1.34 2015/03/11 08:49:19 gienah Exp $
+
+*cairo-0.13.1.0 (11 Mar 2015)
+
+ 11 Mar 2015; Mark Wright <gienah@gentoo.org> +cairo-0.13.1.0.ebuild:
+ Bump cairo to 0.13.1.0
*cairo-0.13.0.5 (13 Dec 2014)
diff --git a/dev-haskell/cairo/cairo-0.13.1.0.ebuild b/dev-haskell/cairo/cairo-0.13.1.0.ebuild
new file mode 100644
index 000000000000..7335d279b4ee
--- /dev/null
+++ b/dev-haskell/cairo/cairo-0.13.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/cairo-0.13.1.0.ebuild,v 1.1 2015/03/11 08:49:19 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Cairo library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+pdf +postscript +svg"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ x11-libs/cairo[svg?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -e "s@#include<cairo-features.h>@#define $(usex amd64 __x86_64__ __i386__)\n#include<cairo-features.h>@" \
+ -i "${S}"/Graphics/Rendering/Cairo.hs \
+ || die "Could not define ABI in Graphics/Rendering/Cairo.hs"
+ # workaround for module order
+ cabal_chdeps \
+ 'other-modules:' 'exposed-modules:'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag pdf cairo_pdf) \
+ $(cabal_flag postscript cairo_ps) \
+ $(cabal_flag svg cairo_svg)
+}