summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-10 13:54:07 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-10 13:54:07 +0000
commit9df190550d25ada73cc2c2afa5e619627e12aff8 (patch)
treeeff8f954b3cfc4915b2d14b29ee489505d8a539e /dev-java/commons-el
parentUpdate Hardened-PHP digests. (diff)
downloadgentoo-2-9df190550d25ada73cc2c2afa5e619627e12aff8.tar.gz
gentoo-2-9df190550d25ada73cc2c2afa5e619627e12aff8.tar.bz2
gentoo-2-9df190550d25ada73cc2c2afa5e619627e12aff8.zip
cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/commons-el')
-rw-r--r--dev-java/commons-el/commons-el-1.0.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-java/commons-el/commons-el-1.0.ebuild b/dev-java/commons-el/commons-el-1.0.ebuild
index 158e47c8f7fd..121e0ed37584 100644
--- a/dev-java/commons-el/commons-el-1.0.ebuild
+++ b/dev-java/commons-el/commons-el-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0.ebuild,v 1.11 2005/05/29 15:47:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0.ebuild,v 1.12 2005/07/10 13:54:07 axxo Exp $
inherit java-pkg
@@ -11,12 +11,13 @@ LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
IUSE="jikes source"
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/servletapi-2.4"
DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-1.5
+ >=dev-java/ant-core-1.5
+ ${RDEPEND}
jikes? ( dev-java/jikes )
source? ( app-arch/zip )"
-RDEPEND=">=virtual/jdk-1.4
- >=dev-java/servletapi-2.4"
S=${WORKDIR}/${P}-src
@@ -25,15 +26,14 @@ src_unpack() {
cd ${S}
mv build.properties build.properties.old
- local SAPI="`java-config -p servletapi-2.4`"
- echo "servlet-api.jar=${SAPI/*:/}" >> build.properties
- echo "jsp-api.jar=${SAPI/:*/}" >> build.properties
- echo "junit.jar = `java-config --classpath=junit`" >> build.properties
+ echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
+ echo "jsp-api.jar=$(java-pkg_getjar servletapi-2.4 jsp-api.jar)" >> build.properties
+ echo "junit.jar = $(java-pkg_getjars junit)" >> build.properties
echo "servletapi.build.notrequired = true" >> build.properties
echo "jspapi.build.notrequired = true" >> build.properties
# Build.xml is broken, fix it
- sed -i "s:../LICENSE:./LICENSE.txt:" build.xml
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
}
src_compile() {
@@ -42,7 +42,7 @@ src_compile() {
ant ${antflags} || die "compile problem"
}
-src_install () {
+src_install() {
java-pkg_dojar dist/${PN}.jar || die "Unable to install"
dodoc LICENSE.txt RELEASE-NOTES.txt
dohtml STATUS.html PROPOSAL.html