summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-06-12 13:59:48 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-06-12 13:59:48 +0000
commit653206adf18bf5925094bec5b66c64eb0e395a0a (patch)
treec628c39c1e81310352a28495d8ed349c9a83f113 /dev-java/istack-commons-runtime
parentRestore previous ebuild and create a revbump instead. (diff)
downloadgentoo-2-653206adf18bf5925094bec5b66c64eb0e395a0a.tar.gz
gentoo-2-653206adf18bf5925094bec5b66c64eb0e395a0a.tar.bz2
gentoo-2-653206adf18bf5925094bec5b66c64eb0e395a0a.zip
Version bump. Fix bug 188015.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-java/istack-commons-runtime')
-rw-r--r--dev-java/istack-commons-runtime/ChangeLog11
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild22
2 files changed, 30 insertions, 3 deletions
diff --git a/dev-java/istack-commons-runtime/ChangeLog b/dev-java/istack-commons-runtime/ChangeLog
index d00b3491bd23..357ad05c5859 100644
--- a/dev-java/istack-commons-runtime/ChangeLog
+++ b/dev-java/istack-commons-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/istack-commons-runtime
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/ChangeLog,v 1.14 2012/04/13 18:08:40 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/ChangeLog,v 1.15 2015/06/12 13:59:48 monsieurp Exp $
+
+*istack-commons-runtime-2.22 (12 Jun 2015)
+
+ 12 Jun 2015; Patrice Clement <monsieurp@gentoo.org>
+ +istack-commons-runtime-2.22.ebuild:
+ Version bump. Fix bug 188015.
13 Apr 2012; Ulrich Müller <ulm@gentoo.org>
istack-commons-runtime-20090620-r1.ebuild:
@@ -66,4 +72,3 @@
01 May 2007; Krzysiek Pawlik <nelchael@gentoo.org> +metadata.xml,
+istack-commons-runtime-20070122.ebuild:
Initial commit of istack-commons-runtime.
-
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild
new file mode 100644
index 000000000000..fa03a0b46083
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/istack-commons-runtime-2.22.ebuild,v 1.1 2015/06/12 13:59:48 monsieurp Exp $
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN=${PN%%-*}
+
+DESCRIPTION="IStack Commons - Runtime jar"
+HOMEPAGE="https://istack-commons.java.net"
+SRC_URI="https://maven.java.net/content/repositories/releases/com/sun/${MY_PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="CDDL"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"