summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-01-28 20:52:04 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-01-28 20:52:04 +0000
commit2a535e13f39050f9cfa2d482c4504a8351fd2148 (patch)
tree4bc21e31b8b2c9bd50ef73c39eb879cd0d01fe0a /dev-java/tagunit
parentStable on MIPS; bug #164196 (diff)
downloadgentoo-2-2a535e13f39050f9cfa2d482c4504a8351fd2148.tar.gz
gentoo-2-2a535e13f39050f9cfa2d482c4504a8351fd2148.tar.bz2
gentoo-2-2a535e13f39050f9cfa2d482c4504a8351fd2148.zip
Migrated to gen 2, updated copyrights
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-java/tagunit')
-rw-r--r--dev-java/tagunit/ChangeLog10
-rw-r--r--dev-java/tagunit/files/digest-tagunit-1.0.12
-rw-r--r--dev-java/tagunit/files/digest-tagunit-1.0.1-r13
-rw-r--r--dev-java/tagunit/tagunit-1.0.1-r1.ebuild49
-rw-r--r--dev-java/tagunit/tagunit-1.0.1.ebuild4
5 files changed, 64 insertions, 4 deletions
diff --git a/dev-java/tagunit/ChangeLog b/dev-java/tagunit/ChangeLog
index 4930c63823a1..8ddee44ab8b8 100644
--- a/dev-java/tagunit/ChangeLog
+++ b/dev-java/tagunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tagunit
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.9 2005/04/30 21:17:18 luckyduck Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.10 2007/01/28 20:52:04 wltjr Exp $
+
+*tagunit-1.0.1-r1 (28 Jan 2007)
+
+ 28 Jan 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +tagunit-1.0.1-r1.ebuild:
+ Migrated to gen 2, updated copyrights
30 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> tagunit-1.0.1.ebuild:
added ~ppc to KEYWORDS. introduced support for the source useflag
diff --git a/dev-java/tagunit/files/digest-tagunit-1.0.1 b/dev-java/tagunit/files/digest-tagunit-1.0.1
index 9d05b99e5c1a..1713efda9832 100644
--- a/dev-java/tagunit/files/digest-tagunit-1.0.1
+++ b/dev-java/tagunit/files/digest-tagunit-1.0.1
@@ -1 +1,3 @@
MD5 1e70fff14c69887cd7ac554c586cf49d tagunit-1.0.1-src.zip 290460
+RMD160 0b2e281b68576d943de5437b3503bf8fc47ecb8c tagunit-1.0.1-src.zip 290460
+SHA256 5ecac67f63cbcde036caaf08a4dc5d544b644337e9ed0afd7e30117f5a8f940e tagunit-1.0.1-src.zip 290460
diff --git a/dev-java/tagunit/files/digest-tagunit-1.0.1-r1 b/dev-java/tagunit/files/digest-tagunit-1.0.1-r1
new file mode 100644
index 000000000000..1713efda9832
--- /dev/null
+++ b/dev-java/tagunit/files/digest-tagunit-1.0.1-r1
@@ -0,0 +1,3 @@
+MD5 1e70fff14c69887cd7ac554c586cf49d tagunit-1.0.1-src.zip 290460
+RMD160 0b2e281b68576d943de5437b3503bf8fc47ecb8c tagunit-1.0.1-src.zip 290460
+SHA256 5ecac67f63cbcde036caaf08a4dc5d544b644337e9ed0afd7e30117f5a8f940e tagunit-1.0.1-src.zip 290460
diff --git a/dev-java/tagunit/tagunit-1.0.1-r1.ebuild b/dev-java/tagunit/tagunit-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..4b9d2be68cfa
--- /dev/null
+++ b/dev-java/tagunit/tagunit-1.0.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1-r1.ebuild,v 1.1 2007/01/28 20:52:04 wltjr Exp $
+
+inherit java-ant-2 java-pkg-2
+
+DESCRIPTION="TagUnit is a tag library for testing custom tags within JSP pages."
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://www.tagunit.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc source"
+
+RDEPEND="|| ( =virtual/jre-1.3 =virtual/jre-1.4* )
+ =dev-java/servletapi-2.4*"
+
+DEPEND=" || ( =virtual/jdk-1.3 =virtual/jdk-1.4* )
+ ${RDEPEND}
+ >=dev-java/ant-core-1.6
+ app-arch/unzip
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${P}-src/tagunit-core"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ java-ant_rewrite-classpath
+}
+
+src_compile() {
+ echo ${PV} > ../version.txt
+ mkdir ../lib
+
+ local antflags="build"
+ antflags="${antflags} -Dgentoo.classpath=$(java-pkg_getjars ant-core,servletapi-2.4)"
+ eant ${antflags} $(use_doc javadoc)
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ cd ${S}/..
+ dodoc changes.txt readme.txt
+ use doc && java-pkg_dohtml -r doc/api/*
+ use source && java-pkg_dosrc tagunit-core/src/*
+}
diff --git a/dev-java/tagunit/tagunit-1.0.1.ebuild b/dev-java/tagunit/tagunit-1.0.1.ebuild
index bac15aa5c2b2..802217ff1d7b 100644
--- a/dev-java/tagunit/tagunit-1.0.1.ebuild
+++ b/dev-java/tagunit/tagunit-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1.ebuild,v 1.11 2005/07/15 14:39:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1.ebuild,v 1.12 2007/01/28 20:52:04 wltjr Exp $
inherit java-pkg