summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-19 09:49:19 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-19 09:49:19 +0000
commit57e66509f8aef6a83a3052316e3f398929dce886 (patch)
tree43ebe03ec13468ba4fb99fb01cc4506e87541515 /dev-lang/v8
parentVersion bump #313101 (which should also fix #270062 by Diego Elio Pettenò, #... (diff)
downloadgentoo-2-57e66509f8aef6a83a3052316e3f398929dce886.tar.gz
gentoo-2-57e66509f8aef6a83a3052316e3f398929dce886.tar.bz2
gentoo-2-57e66509f8aef6a83a3052316e3f398929dce886.zip
Version bump. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.4.9.6.ebuild89
-rw-r--r--dev-lang/v8/v8-2.5.6.ebuild (renamed from dev-lang/v8/v8-2.4.9.10.ebuild)14
3 files changed, 16 insertions, 95 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 98a85318b00b..0724cb9473d9 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.13 2010/11/12 11:41:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.14 2010/11/19 09:49:19 phajdan.jr Exp $
+
+*v8-2.5.6 (19 Nov 2010)
+
+ 19 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.4.9.6.ebuild,
+ -v8-2.4.9.10.ebuild, +v8-2.5.6.ebuild:
+ Version bump. Remove old.
*v8-2.4.9.13 (12 Nov 2010)
diff --git a/dev-lang/v8/v8-2.4.9.6.ebuild b/dev-lang/v8/v8-2.4.9.6.ebuild
deleted file mode 100644
index 2b1d02c62ad1..000000000000
--- a/dev-lang/v8/v8-2.4.9.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.6.ebuild,v 1.1 2010/10/29 08:34:53 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib subversion toolchain-funcs
-
-ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}
- >=dev-util/scons-1.3.0"
-
-v8_scons_opts() {
- echo "$(echo ${MAKEOPTS} | sed -r 's/.*(-j\s*|--jobs=)([0-9]+).*/-j\2/')"
-}
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Locally fix http://code.google.com/p/v8/issues/detail?id=773.
- epatch "${FILESDIR}"/${PN}-upstream-bug-773-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- if use readline; then
- myconf="${myconf} console=readline"
- else
- myconf="${myconf} console=dumb"
- fi
-
- scons library=shared soname=on $(v8_scons_opts) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-2.4.9.10.ebuild b/dev-lang/v8/v8-2.5.6.ebuild
index 0a31a61b8281..20c1f84b1d95 100644
--- a/dev-lang/v8/v8-2.4.9.10.ebuild
+++ b/dev-lang/v8/v8-2.5.6.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.10.ebuild,v 1.3 2010/11/02 08:49:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.6.ebuild,v 1.1 2010/11/19 09:49:19 phajdan.jr Exp $
EAPI="2"
-inherit eutils flag-o-matic multilib scons-utils subversion toolchain-funcs
-
-ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
+inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -19,10 +18,13 @@ IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
DEPEND="${RDEPEND}"
-EXTRA_ESCONS="library=shared soname=on"
+EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
pkg_setup() {
tc-export AR CC CXX RANLIB
+
+ # Make the build respect LDFLAGS.
+ export LINKFLAGS="${LDFLAGS}"
}
src_prepare() {
@@ -53,6 +55,8 @@ src_compile() {
myconf+=" arch=x64"
elif [[ $myarch = x86 ]] ; then
myconf+=" arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ myconf+=" arch=arm"
else
die "Failed to determine target arch, got '$myarch'."
fi