summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-01-13 21:20:56 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-01-13 21:20:56 +0000
commite7c9d5392fb0e7eea03cbc634a79c8124e5f2bfb (patch)
tree46a648ddbafc0424b3e59fb0d5a01b3c3bc8b1ee /dev-libs/STLport
parentMultilib fix for additional posix headers. (diff)
downloadgentoo-2-e7c9d5392fb0e7eea03cbc634a79c8124e5f2bfb.tar.gz
gentoo-2-e7c9d5392fb0e7eea03cbc634a79c8124e5f2bfb.tar.bz2
gentoo-2-e7c9d5392fb0e7eea03cbc634a79c8124e5f2bfb.zip
Added patch for the unittests. Added static USE-flag.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-libs/STLport')
-rw-r--r--dev-libs/STLport/ChangeLog7
-rw-r--r--dev-libs/STLport/STLport-5.1.0.ebuild19
-rw-r--r--dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch11
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-libs/STLport/ChangeLog b/dev-libs/STLport/ChangeLog
index c17079ec88e9..8869f7c7ff23 100644
--- a/dev-libs/STLport/ChangeLog
+++ b/dev-libs/STLport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/STLport
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.40 2007/01/13 13:48:52 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.41 2007/01/13 21:20:56 dev-zero Exp $
+
+ 13 Jan 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/STLport-5.1.0-wrong_russian_currency_name.patch,
+ STLport-5.1.0.ebuild:
+ Added patch for the unittests. Added static USE-flag.
13 Jan 2007; Tiziano Müller <dev-zero@gentoo.org> STLport-5.1.0.ebuild:
Disabled parallel builds for building the library as well.
diff --git a/dev-libs/STLport/STLport-5.1.0.ebuild b/dev-libs/STLport/STLport-5.1.0.ebuild
index a15e39fab900..65d525f9bea7 100644
--- a/dev-libs/STLport/STLport-5.1.0.ebuild
+++ b/dev-libs/STLport/STLport-5.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.0.ebuild,v 1.8 2007/01/13 13:48:52 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.0.ebuild,v 1.9 2007/01/13 21:20:56 dev-zero Exp $
inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
@@ -11,7 +11,7 @@ HOMEPAGE="http://stlport.sourceforge.net/"
SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
-IUSE="boost"
+IUSE="boost static"
DEPEND="boost? ( dev-libs/boost )"
RDEPEND="${RDEPEND}"
@@ -22,6 +22,7 @@ src_unpack() {
# It should be save to apply this on non-ppc systems as well
epatch "${FILESDIR}/${P}-ppc.patch"
+ epatch "${FILESDIR}/${P}-wrong_russian_currency_name.patch"
sed -i \
-e 's/\(OPT += \)-O2/\1/' \
@@ -69,16 +70,26 @@ src_compile() {
CFLAGS := ${CFLAGS}
EOF
+ local targets
+ targets="all-shared"
+ use static && targets="${targets} all-static"
+
# The build-system is broken in respect to parallel builds, bug #161881
emake \
-j1 \
-C build/lib \
-f gcc.mak \
- depend all || die "Compile failed"
+ depend ${targets} || die "Compile failed"
}
src_install() {
- dolib.so build/lib/obj/*/*/libstlport*.so* || die "dolib.so failed"
+ emake -C build/lib -f gcc.mak install
+ dolib.so lib/*
+
+ if use static ; then
+ emake -C build/lib -f gcc.mak install-static
+ dolib.a lib/*.a
+ fi
insinto /usr/include
doins -r stlport
diff --git a/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch b/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch
new file mode 100644
index 000000000000..5735b17205b8
--- /dev/null
+++ b/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch
@@ -0,0 +1,11 @@
+--- test/unit/locale_test.cpp.orig 2007-01-13 21:56:42.000000000 +0100
++++ test/unit/locale_test.cpp 2007-01-13 21:57:14.000000000 +0100
+@@ -35,7 +35,7 @@
+ #else
+ " " },
+ #endif
+- { "ru_RU.koi8r", ",", ".", "RUR ", "", "", "\xd2\xd5\xc2", ".", " " },
++ { "ru_RU.koi8r", ",", ".", "RUB ", "", "", "\xd2\xd5\xc2", ".", " " },
+ { "en_GB", ".", ",", "GBP ", "", "\xa3", "", ".", "," },
+ { "en_US", ".", ",", "USD ", "", "$", "", ".", "," },
+ { "C", ".", ",", "", "", "", "", " ", " " },