summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-06-11 06:45:19 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-06-11 06:45:19 +0000
commit15f701547b0613bdc0e4d31cca6dd77ee9831118 (patch)
treee829b7d16c9bfd6d65078aba24ebd89e9acf98e1 /dev-libs/gobject-introspection
parentCleanup (diff)
downloadgentoo-2-15f701547b0613bdc0e4d31cca6dd77ee9831118.tar.gz
gentoo-2-15f701547b0613bdc0e4d31cca6dd77ee9831118.tar.bz2
gentoo-2-15f701547b0613bdc0e4d31cca6dd77ee9831118.zip
Bump to 0.6.14. Upstream doesn't like ChangeLogs, so meh. Added USE=test and bumped to EAPI-3 for python eclass lovin'.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog9
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.6.14.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 390b5c49e935..b6c05fcbd7be 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.3 2010/03/19 14:15:08 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.4 2010/06/11 06:45:19 ford_prefect Exp $
+
+*gobject-introspection-0.6.14 (11 Jun 2010)
+
+ 11 Jun 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +gobject-introspection-0.6.14.ebuild:
+ Bump to 0.6.14. Upstream doesn't like ChangeLogs, so meh. Added USE=test
+ and bumped to EAPI-3 for python eclass lovin'.
*gobject-introspection-0.6.9 (19 Mar 2010)
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.6.14.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.6.14.ebuild
new file mode 100644
index 000000000000..f85cf364dbb1
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.6.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.6.14.ebuild,v 1.1 2010/06/11 06:45:19 ford_prefect Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( x11-libs/cairo )"
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_configure() {
+ econf $(use_enable test tests) || die "econf failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}