summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-21 09:10:12 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-21 09:10:12 +0000
commitcf11ed14e961bd45d4cd3664f92537085246537b (patch)
tree049f4db7ded6f182f6db4a0f418fc756f5f042a6 /dev-libs/libebml
parentFix usage of kernel headers from /usr/src, wrt bug #285376. Thanks to Coacher... (diff)
downloadgentoo-2-cf11ed14e961bd45d4cd3664f92537085246537b.tar.gz
gentoo-2-cf11ed14e961bd45d4cd3664f92537085246537b.tar.bz2
gentoo-2-cf11ed14e961bd45d4cd3664f92537085246537b.zip
Version bump and add subslot.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/libebml')
-rw-r--r--dev-libs/libebml/ChangeLog10
-rw-r--r--dev-libs/libebml/files/libebml-1.3.0-makefile.patch102
-rw-r--r--dev-libs/libebml/libebml-1.3.0.ebuild62
3 files changed, 172 insertions, 2 deletions
diff --git a/dev-libs/libebml/ChangeLog b/dev-libs/libebml/ChangeLog
index fdd190524015..58ff05ac19ef 100644
--- a/dev-libs/libebml/ChangeLog
+++ b/dev-libs/libebml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libebml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.121 2012/05/29 13:32:31 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.122 2013/03/21 09:10:12 radhermit Exp $
+
+*libebml-1.3.0 (21 Mar 2013)
+
+ 21 Mar 2013; Tim Harder <radhermit@gentoo.org> +libebml-1.3.0.ebuild,
+ +files/libebml-1.3.0-makefile.patch:
+ Version bump and add subslot.
29 May 2012; Alexis Ballier <aballier@gentoo.org> libebml-1.2.2.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-libs/libebml/files/libebml-1.3.0-makefile.patch b/dev-libs/libebml/files/libebml-1.3.0-makefile.patch
new file mode 100644
index 000000000000..8c6309de4554
--- /dev/null
+++ b/dev-libs/libebml/files/libebml-1.3.0-makefile.patch
@@ -0,0 +1,102 @@
+--- libebml-release-1.3.0/make/linux/Makefile
++++ libebml-release-1.3.0/make/linux/Makefile
+@@ -50,6 +50,8 @@
+ LIBRARY=libebml.a
+ LIBRARY_SO=libebml.so
+ LIBRARY_SO_VER=libebml.so.4
++LIBRARY_DYLIB=libebml.dylib
++LIBRARY_DYLIB_VER=libebml.4.dylib
+
+ # source-files
+ sources:=$(wildcard ${SRC_DIR}*$(EXTENSION))
+@@ -66,7 +68,7 @@
+ DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE)
+
+ ifeq (Darwin,$(shell uname -s))
+-all: staticlib
++all: staticlib macholib
+ else
+ all: staticlib sharedlib
+ endif
+@@ -75,8 +77,10 @@
+
+ sharedlib: $(LIBRARY_SO)
+
++macholib: $(LIBRARY_DYLIB)
++
+ lib:
+- @echo "Use the 'staticlib', 'sharedlib' or 'all' targets."
++ @echo "Use the 'staticlib', 'sharedlib', 'macholib' or 'all' targets."
+ @false
+
+ # Build rules
+@@ -91,15 +95,22 @@
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
++ $(CXX) $(LDFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
+ rm -f $(LIBRARY_SO)
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
++$(LIBRARY_DYLIB): $(objects_so)
++ $(CXX) $(LDFLAGS) -dynamiclib -install_name $(libdir)/$(LIBRARY_DYLIB_VER) -o $(LIBRARY_DYLIB_VER) $(objects_so) $(LIBS)
++ rm -f $(LIBRARY_DYLIB)
++ ln -s $(LIBRARY_DYLIB_VER) $(LIBRARY_DYLIB)
++
+ clean:
+ rm -f $(objects) $(objects_so)
+ rm -f $(LIBRARY)
+ rm -f $(LIBRARY_SO)
+ rm -f $(LIBRARY_SO_VER)
++ rm -f $(LIBRARY_DYLIB)
++ rm -f $(LIBRARY_DYLIB_VER)
+ rm -f CORE
+
+ distclean dist-clean: clean
+@@ -116,30 +127,34 @@
+ done
+
+ ifeq (Darwin,$(shell uname -s))
+-install: install_staticlib install_headers
++install: install_staticlib install_macholib install_headers
+ else
+ install: install_staticlib install_sharedlib install_headers
+ endif
+
+ install_headers:
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)
+ for i in $(INCLUDE_DIR)/*.h; do \
+- $(INSTALL) $(INSTALL_OPTS) $$i $(includedir) ; \
++ $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir) ; \
+ done
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(includedir)/c
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(includedir)/c
+ for i in $(INCLUDE_DIR)/c/*.h; do \
+- $(INSTALL) $(INSTALL_OPTS) $$i $(includedir)/c ; \
++ $(INSTALL) $(INSTALL_OPTS) $$i $(DESTDIR)$(includedir)/c ; \
+ done
+
+ install_staticlib: $(LIBRARY)
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
+- $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(libdir)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY) $(DESTDIR)$(libdir)
+
+ install_sharedlib: $(LIBRARY_SO)
+- $(INSTALL) $(INSTALL_DIR_OPTS) -d $(libdir)
+- $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(libdir)
+- ln -fs $(LIBRARY_SO_VER) $(libdir)/$(LIBRARY_SO)
+-
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_SO_VER) $(DESTDIR)$(libdir)
++ ln -fs $(LIBRARY_SO_VER) $(DESTDIR)$(libdir)/$(LIBRARY_SO)
++
++install_macholib: $(LIBRARY_DYLIB)
++ $(INSTALL) $(INSTALL_DIR_OPTS) -d $(DESTDIR)$(libdir)
++ $(INSTALL) $(INSTALL_OPTS_LIB) $(LIBRARY_DYLIB_VER) $(DESTDIR)$(libdir)
++ ln -fs $(LIBRARY_DYLIB_VER) $(DESTDIR)$(libdir)/$(LIBRARY_DYLIB)
+
+ ifneq ($(wildcard .depend),)
+ include .depend
diff --git a/dev-libs/libebml/libebml-1.3.0.ebuild b/dev-libs/libebml/libebml-1.3.0.ebuild
new file mode 100644
index 000000000000..f94436324baf
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-1.3.0.ebuild,v 1.1 2013/03/21 09:10:12 radhermit Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://github.com/Matroska-Org/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${PN}-release-${PV}/make/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ sed -i "s:\(DEBUGFLAGS=\)-g :\1:" Makefile || die
+}
+
+src_compile() {
+ local targets
+ if [[ ${CHOST} != *-darwin* ]] ; then
+ targets="sharedlib"
+ else
+ targets="macholib"
+ fi
+ use static-libs && targets+=" staticlib"
+
+ # keep the prefix in here to make sure the binary is built with a correct
+ # install_name on Darwin
+ emake \
+ prefix="${EPREFIX}"/usr \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ $(use debug && echo DEBUG=yes || echo DEBUG=no) \
+ ${targets}
+}
+
+src_install() {
+ local targets="install_headers"
+ if [[ ${CHOST} != *-darwin* ]] ; then
+ targets+=" install_sharedlib"
+ else
+ targets+=" install_macholib"
+ fi
+ use static-libs && targets+=" install_staticlib"
+
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}"/usr \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
+ ${targets}
+
+ dodoc "${WORKDIR}"/${PN}-release-${PV}/ChangeLog
+}