summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-26 19:23:30 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-26 19:23:30 +0000
commit26aee29ef684b12897846844059dba6a0387f70d (patch)
tree9731e128f44c31ac1ebff6d9c705fe83749c3630 /dev-perl/ORLite/ORLite-1.980.0-r1.ebuild
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-26aee29ef684b12897846844059dba6a0387f70d.tar.gz
gentoo-2-26aee29ef684b12897846844059dba6a0387f70d.tar.bz2
gentoo-2-26aee29ef684b12897846844059dba6a0387f70d.zip
bumped EAPI to 5 to help with dev-lang/perl upgrade
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-perl/ORLite/ORLite-1.980.0-r1.ebuild')
-rw-r--r--dev-perl/ORLite/ORLite-1.980.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild b/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild
new file mode 100644
index 000000000000..c1dcab3c7629
--- /dev/null
+++ b/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/ORLite/ORLite-1.980.0-r1.ebuild,v 1.1 2014/08/26 19:23:30 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.98
+inherit perl-module
+
+DESCRIPTION="Extremely light weight SQLite-specific ORM"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=virtual/perl-File-Path-2.08
+ >=virtual/perl-File-Temp-0.20
+ >=dev-perl/Params-Util-1
+ >=dev-perl/DBI-1.607
+ >=dev-perl/DBD-SQLite-1.27
+ >=dev-perl/File-Remove-1.40
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ >=dev-perl/Test-Script-1.06
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+
+SRC_TEST=do