summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2012-03-13 13:17:27 +0000
committerJoshua Kinard <kumba@gentoo.org>2012-03-13 13:17:27 +0000
commitd03edf591ab978328d84d17404756153ff707c21 (patch)
treecdb47f797fab77c30517477edcb77209cb1c820c /dev-php/PEAR-Mail_Mime
parentMarking libcap-ng-0.6.6 ppc for bug 407773 (diff)
downloadgentoo-2-d03edf591ab978328d84d17404756153ff707c21.tar.gz
gentoo-2-d03edf591ab978328d84d17404756153ff707c21.tar.bz2
gentoo-2-d03edf591ab978328d84d17404756153ff707c21.zip
The 1.5.2 patch does not apply to 1.8.3 any further. Added a tweaked version that does apply to 1.8.3 to prevent this ebuild from failing. Closes #407969. Also changed src_unpack to src_prepare for EAPI4.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Mail_Mime')
-rw-r--r--dev-php/PEAR-Mail_Mime/ChangeLog8
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild9
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch74
3 files changed, 84 insertions, 7 deletions
diff --git a/dev-php/PEAR-Mail_Mime/ChangeLog b/dev-php/PEAR-Mail_Mime/ChangeLog
index 15b253a3a19a..c116a82571d7 100644
--- a/dev-php/PEAR-Mail_Mime/ChangeLog
+++ b/dev-php/PEAR-Mail_Mime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-Mail_Mime
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/ChangeLog,v 1.75 2012/03/12 09:48:42 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/ChangeLog,v 1.76 2012/03/13 13:17:27 kumba Exp $
+
+ 13 Mar 2012; Joshua Kinard <kumba@gentoo.org>
+ +files/1.8.3-php-pass-by-reference-fix.patch, PEAR-Mail_Mime-1.8.3.ebuild:
+ The 1.5.2 patch does not apply to 1.8.3 any further. Added a tweaked version
+ that does apply to 1.8.3 to prevent this ebuild from failing. Closes #407969.
+ Also changed src_unpack to src_prepare for EAPI4.
*PEAR-Mail_Mime-1.8.3 (12 Mar 2012)
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild
index 630c557bb934..fc8b58d6ecab 100644
--- a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild,v 1.1 2012/03/12 09:48:42 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.8.3.ebuild,v 1.2 2012/03/13 13:17:27 kumba Exp $
EAPI="4"
@@ -15,10 +15,7 @@ IUSE=""
PDEPEND="dev-php/PEAR-Mail_mimeDecode"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# see Bug 125451; http://pear.php.net/bugs/bug.php?id=5333
- epatch "${FILESDIR}"/1.5.2-php-pass-by-reference-fix.patch
+ epatch "${FILESDIR}"/${PV}-php-pass-by-reference-fix.patch
}
diff --git a/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
new file mode 100644
index 000000000000..ab87c19287e6
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
@@ -0,0 +1,74 @@
+--- a/Mail/mime.php.orig 2007-08-16 12:16:47.000000000 +0200
++++ b/Mail/mime.php 2007-08-16 12:25:07.000000000 +0200
+@@ -376,7 +376,7 @@
+ * @return string contents of $file_name
+ * @access private
+ */
+- function &_file2str($file_name)
++ function _file2str($file_name)
+ {
+ if (!is_readable($file_name)) {
+ $err = PEAR::raiseError('File is not readable ' . $file_name);
+@@ -413,7 +413,7 @@
+ * @return object The text mimePart object
+ * @access private
+ */
+- function &_addTextPart(&$obj, $text)
++ function _addTextPart(&$obj, $text)
+ {
+ $params['content_type'] = 'text/plain';
+ $params['encoding'] = $this->_build_params['text_encoding'];
+@@ -437,7 +437,7 @@
+ * @return object The html mimePart object
+ * @access private
+ */
+- function &_addHtmlPart(&$obj)
++ function _addHtmlPart(&$obj)
+ {
+ $params['content_type'] = 'text/html';
+ $params['encoding'] = $this->_build_params['html_encoding'];
+@@ -459,7 +459,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addMixedPart()
++ function _addMixedPart()
+ {
+ $params = array();
+ $params['content_type'] = 'multipart/mixed';
+@@ -480,7 +480,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addAlternativePart(&$obj)
++ function _addAlternativePart(&$obj)
+ {
+ $params['content_type'] = 'multipart/alternative';
+ if (is_object($obj)) {
+@@ -502,7 +502,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addRelatedPart(&$obj)
++ function _addRelatedPart(&$obj)
+ {
+ $params['content_type'] = 'multipart/related';
+ if (is_object($obj)) {
+@@ -523,7 +523,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addHtmlImagePart(&$obj, $value)
++ function _addHtmlImagePart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = 'base64';
+@@ -546,7 +546,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addAttachmentPart(&$obj, $value)
++ function _addAttachmentPart(&$obj, $value)
+ {
+ $params['dfilename'] = $value['name'];
+ $params['encoding'] = $value['encoding'];