summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-07-02 02:49:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-07-02 02:49:07 +0000
commitdd943ef609f8134f31e30baf8ed3ae8292b704eb (patch)
tree7dd8d3d601735a452ed968bd069715a79a10721c /dev-php4
parentversion bump and jbig support for bugs 133477 and 137613 (diff)
downloadgentoo-2-dd943ef609f8134f31e30baf8ed3ae8292b704eb.tar.gz
gentoo-2-dd943ef609f8134f31e30baf8ed3ae8292b704eb.tar.bz2
gentoo-2-dd943ef609f8134f31e30baf8ed3ae8292b704eb.zip
Version bump.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/pecl-memcache/ChangeLog8
-rw-r--r--dev-php4/pecl-memcache/files/digest-pecl-memcache-2.0.43
-rw-r--r--dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php4/pecl-memcache/ChangeLog b/dev-php4/pecl-memcache/ChangeLog
index de6b12863c7b..8fb3fd18ac58 100644
--- a/dev-php4/pecl-memcache/ChangeLog
+++ b/dev-php4/pecl-memcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/pecl-memcache
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/ChangeLog,v 1.11 2006/05/27 00:52:30 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/ChangeLog,v 1.12 2006/07/02 02:49:07 robbat2 Exp $
+
+*pecl-memcache-2.0.4 (02 Jul 2006)
+
+ 02 Jul 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +pecl-memcache-2.0.4.ebuild:
+ Version bump.
27 May 2006; Luca Longinotti <chtekk@gentoo.org>
pecl-memcache-2.0.1.ebuild:
diff --git a/dev-php4/pecl-memcache/files/digest-pecl-memcache-2.0.4 b/dev-php4/pecl-memcache/files/digest-pecl-memcache-2.0.4
new file mode 100644
index 000000000000..ad07cfbab024
--- /dev/null
+++ b/dev-php4/pecl-memcache/files/digest-pecl-memcache-2.0.4
@@ -0,0 +1,3 @@
+MD5 35d46450ae9728856a2cc98cb8ec053c memcache-2.0.4.tgz 17778
+RMD160 da27515d2d86a4bcae130dac6b89e78ab44136ce memcache-2.0.4.tgz 17778
+SHA256 548419a9ff84840576ce547e3b2c6111ddebd4ce909f78a8b82b55293940e21e memcache-2.0.4.tgz 17778
diff --git a/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild b/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild
new file mode 100644
index 000000000000..220efb183ca4
--- /dev/null
+++ b/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/pecl-memcache-2.0.4.ebuild,v 1.1 2006/07/02 02:49:07 robbat2 Exp $
+
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ sys-libs/zlib"
+
+need_php_by_category
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-memcache --with-zlib-dir=/usr"
+ php-ext-pecl-r1_src_compile
+}