summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-29 21:55:05 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-29 21:55:05 +0000
commit3e61c9785c9ae81936066fc91ee3d574af8a1d60 (patch)
tree984412ddb6cf403614169852d9745f4535cdda84 /dev-python/boto
parentRemove old. (diff)
downloadgentoo-2-3e61c9785c9ae81936066fc91ee3d574af8a1d60.tar.gz
gentoo-2-3e61c9785c9ae81936066fc91ee3d574af8a1d60.tar.bz2
gentoo-2-3e61c9785c9ae81936066fc91ee3d574af8a1d60.zip
Version bump.
(Portage version: 2.2.0_alpha133/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.6.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 84e561a32ac0..86ed63125985 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.51 2012/07/29 16:59:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.52 2012/09/29 21:55:05 radhermit Exp $
+
+*boto-2.6.0 (29 Sep 2012)
+
+ 29 Sep 2012; Tim Harder <radhermit@gentoo.org> +boto-2.6.0.ebuild:
+ Version bump.
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> boto-2.3.0.ebuild:
sparc stable wrt #416861
diff --git a/dev-python/boto/boto-2.6.0.ebuild b/dev-python/boto/boto-2.6.0.ebuild
new file mode 100644
index 000000000000..b5bb8479c326
--- /dev/null
+++ b/dev-python/boto/boto-2.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.6.0.ebuild,v 1.1 2012/09/29 21:55:05 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://github/boto/boto/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# Requires Amazon Web Services keys to pass some tests
+RESTRICT="test"