summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-06 03:22:24 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-06 03:22:24 +0000
commit153cdb63de7461b7a03afc3b0ef9a4b3fb3b94ac (patch)
treed6f23067f10cf7e4bc1aa00c07c29ccae3339fb5 /dev-python/cairocffi
parentVersion bump; drop old (diff)
downloadgentoo-2-153cdb63de7461b7a03afc3b0ef9a4b3fb3b94ac.tar.gz
gentoo-2-153cdb63de7461b7a03afc3b0ef9a4b3fb3b94ac.tar.bz2
gentoo-2-153cdb63de7461b7a03afc3b0ef9a4b3fb3b94ac.zip
revbump; add another missed dep, wrt bug #546910
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cairocffi')
-rw-r--r--dev-python/cairocffi/ChangeLog7
-rw-r--r--dev-python/cairocffi/cairocffi-0.6-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/cairocffi/ChangeLog b/dev-python/cairocffi/ChangeLog
index f65d79dff27c..5ac92f2b5315 100644
--- a/dev-python/cairocffi/ChangeLog
+++ b/dev-python/cairocffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cairocffi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.9 2015/04/08 08:05:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/ChangeLog,v 1.10 2015/05/06 03:22:24 idella4 Exp $
+
+*cairocffi-0.6-r1 (06 May 2015)
+
+ 06 May 2015; Ian Delaney <idella4@gentoo.org> +cairocffi-0.6-r1.ebuild:
+ revbump; add another missed dep, wrt bug #546910
08 Apr 2015; Michał Górny <mgorny@gentoo.org> cairocffi-0.5.3-r1.ebuild,
cairocffi-0.5.4.ebuild, cairocffi-0.6.ebuild:
diff --git a/dev-python/cairocffi/cairocffi-0.6-r1.ebuild b/dev-python/cairocffi/cairocffi-0.6-r1.ebuild
new file mode 100644
index 000000000000..0e9eefe279f5
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-0.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cairocffi/cairocffi-0.6-r1.ebuild,v 1.1 2015/05/06 03:22:24 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+MY_PN="${PN}"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/SimonSapin/cairocffi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+# xcffib is an optional extra excpet that the testsuite has it a hard coded unconditional component
+RDEPEND=">=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ x11-libs/cairo:0=
+ dev-python/xcffib[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[jpeg]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Intersphinx cause the usual d'loading of objects.inv from TWO online sites
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ https://github.com/SimonSapin/cairocffi/issues/55
+ py.test ${PN}/ || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}