summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-04-19 15:30:10 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-04-19 15:30:10 +0000
commitd22500f15183b7ac66119be96be99dcfe46a51c5 (patch)
tree5aa7ac9ae70e2fa149fc637a21968023297709b3 /dev-python/fuse-python
parentVersion bump. (diff)
downloadgentoo-2-d22500f15183b7ac66119be96be99dcfe46a51c5.tar.gz
gentoo-2-d22500f15183b7ac66119be96be99dcfe46a51c5.tar.bz2
gentoo-2-d22500f15183b7ac66119be96be99dcfe46a51c5.zip
Remove old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-python/fuse-python')
-rw-r--r--dev-python/fuse-python/ChangeLog7
-rw-r--r--dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch32
-rw-r--r--dev-python/fuse-python/files/fuse_python_accept_none.patch75
-rw-r--r--dev-python/fuse-python/fuse-python-0.2.1.ebuild23
4 files changed, 6 insertions, 131 deletions
diff --git a/dev-python/fuse-python/ChangeLog b/dev-python/fuse-python/ChangeLog
index 3ecceaa42f5b..8bbdd17bd585 100644
--- a/dev-python/fuse-python/ChangeLog
+++ b/dev-python/fuse-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/fuse-python
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/ChangeLog,v 1.24 2015/04/19 09:37:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/ChangeLog,v 1.25 2015/04/19 15:30:10 kensington Exp $
+
+ 19 Apr 2015; Michael Palimaka <kensington@gentoo.org>
+ -files/fuse-python-0.2-fix-ctors.patch, -files/fuse_python_accept_none.patch,
+ -fuse-python-0.2.1.ebuild:
+ Remove old.
19 Apr 2015; Pacho Ramos <pacho@gentoo.org> fuse-python-0.2.1-r1.ebuild:
x86 stable wrt bug #535324
diff --git a/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch b/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch
deleted file mode 100644
index 4ec50f2f3508..000000000000
--- a/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- fuse.py
-+++ fuse.py
-@@ -461,13 +462,14 @@
- FUSE, see ``fuse.h``).
- """
-
-- def __init__(self, name, **kw):
-+ def __init__(self, name=None, **kw):
-
- self.l_type = None
- self.l_start = None
- self.l_len = None
- self.l_pid = None
-
-+ kw['name'] = name
- FuseStruct.__init__(self, **kw)
-
-
-@@ -477,11 +479,12 @@
- http://www.opengroup.org/onlinepubs/009695399/basedefs/time.h.html
- """
-
-- def __init__(self, name, **kw):
-+ def __init__(self, name=None, **kw):
-
- self.tv_sec = None
- self.tv_nsec = None
-
-+ kw['name'] = name
- FuseStruct.__init__(self, **kw)
-
-
diff --git a/dev-python/fuse-python/files/fuse_python_accept_none.patch b/dev-python/fuse-python/files/fuse_python_accept_none.patch
deleted file mode 100644
index 9f7180050b9c..000000000000
--- a/dev-python/fuse-python/files/fuse_python_accept_none.patch
+++ /dev/null
@@ -1,75 +0,0 @@
---- fuseparts/_fusemodule.c.old 2007-06-18 16:20:09.000000000 +0200
-+++ fuseparts/_fusemodule.c 2008-04-08 01:18:43.000000000 +0200
-@@ -182,8 +182,50 @@
- * the getattr type functions.
- */
-
--#define fetchattr_soft_d(st, attr, defa) \
-- fetchattr_soft(st, attr) else st->attr = defa
-+// <spaghetti_code> (sorry ...)
-+
-+#define good(attr) _GOOD_SPAGHETTI_ ## attr
-+#define bad(attr) _BAD_SPAGHETTI_ ## attr
-+
-+/*
-+ * This macro checks whether an attribute is available and not None.
-+ * Success --> set attribute and goto _GOOD_SPAGHETTI
-+ * Failure --> goto _BAD_SPAGHETTI
-+ * Error --> goto OUT_DECREF
-+ */
-+#define fetchattr_soft_none_pre(st, attr) \
-+ if (PyObject_HasAttrString(v, #attr)) { \
-+ if (!(pytmp = PyObject_GetAttrString(v, #attr))) \
-+ goto OUT_DECREF; \
-+ else if (pytmp != Py_None) { \
-+ py2attr(st, attr) \
-+ goto good(attr); \
-+ } \
-+ else { \
-+ Py_DECREF(pytmp); \
-+ goto bad(attr); \
-+ } \
-+ } \
-+ goto bad(attr);
-+
-+/**
-+ * Calls fetchattr_soft_none_pre and ignores failure.
-+ */
-+#define fetchattr_soft_none(st, attr) \
-+ fetchattr_soft_none_pre(st, attr); \
-+ good(attr): ; \
-+ bad(attr): ;
-+
-+/**
-+ * Calls fetchattr_soft_none_pre and sets a default value on failure.
-+ */
-+#define fetchattr_soft_d(st, attr, defa) \
-+ fetchattr_soft_none_pre(st, attr); \
-+ bad(attr): \
-+ st->attr = defa; \
-+ good(attr): ;
-+
-+// </spaghetti_code>
-
- #define FETCH_STAT_DATA() \
- fetchattr(st, st_mode); \
-@@ -206,7 +248,7 @@
- * autotools so we just dare to throw these in as is. \
- */ \
- \
-- fetchattr_soft(st, st_rdev); \
-+ fetchattr_soft_none(st, st_rdev); \
- fetchattr_soft_d(st, st_blksize, 4096); \
- fetchattr_soft_d(st, st_blocks, (st->st_size + 511)/512)
-
-@@ -245,6 +287,10 @@
- #endif
-
- #undef fetchattr_soft_d
-+#undef fetchattr_soft_none
-+#undef fetchattr_soft_none_pre
-+#undef good
-+#undef bad
- #undef FETCH_STAT_DATA
-
- static int
diff --git a/dev-python/fuse-python/fuse-python-0.2.1.ebuild b/dev-python/fuse-python/fuse-python-0.2.1.ebuild
deleted file mode 100644
index 29d01b19f65d..000000000000
--- a/dev-python/fuse-python/fuse-python-0.2.1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/fuse-python-0.2.1.ebuild,v 1.4 2012/02/22 07:26:26 patrick Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils distutils
-
-KEYWORDS="amd64 x86"
-DESCRIPTION="Python FUSE bindings"
-HOMEPAGE="http://fuse.sourceforge.net/wiki/index.php/FusePython"
-
-SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=sys-fs/fuse-2.0"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="fuse.py fuseparts"