summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-21 14:58:55 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-21 14:58:55 +0000
commitaa9c6626a10124aa8ea9be3b558a16823cf012ce (patch)
treee0030df1bca0ffe4a413353d68739ce26145c4d0 /dev-python/pygments
parentVersion bump. (diff)
downloadgentoo-2-aa9c6626a10124aa8ea9be3b558a16823cf012ce.tar.gz
gentoo-2-aa9c6626a10124aa8ea9be3b558a16823cf012ce.tar.bz2
gentoo-2-aa9c6626a10124aa8ea9be3b558a16823cf012ce.zip
revbump; update to install bundled bash-completion, patch by E. Uggedal, fixes Bug 01972 by E. Uggedal
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/ChangeLog10
-rw-r--r--dev-python/pygments/pygments-1.6-r1.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/pygments/ChangeLog b/dev-python/pygments/ChangeLog
index 3e64e8c7ff83..826f5a4cd3ec 100644
--- a/dev-python/pygments/ChangeLog
+++ b/dev-python/pygments/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygments
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.117 2013/09/05 18:47:03 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.118 2014/03/21 14:58:55 idella4 Exp $
+
+*pygments-1.6-r1 (21 Mar 2014)
+
+ 21 Mar 2014; Ian Delaney <idella4@gentoo.org> +pygments-1.6-r1.ebuild:
+ revbump; update to install bundled bash-completion, patch by E. Uggedal, fixes
+ Bug 01972 by E. Uggedal
05 Sep 2013; Michał Górny <mgorny@gentoo.org> pygments-1.5-r1.ebuild,
pygments-1.6.ebuild:
diff --git a/dev-python/pygments/pygments-1.6-r1.ebuild b/dev-python/pygments/pygments-1.6-r1.ebuild
new file mode 100644
index 000000000000..ec72e4f79f71
--- /dev/null
+++ b/dev-python/pygments/pygments-1.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/pygments-1.6-r1.ebuild,v 1.1 2014/03/21 14:58:55 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python."
+HOMEPAGE="http://pygments.org/ http://pypi.python.org/pypi/Pygments"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ dev-texlive/texlive-latexrecommended
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+
+ if [[ ${EPYTHON} == python3.* ]]; then
+ # Notes:
+ # -W is not supported by python3.1
+ # -n causes Python to write into hardlinked files
+ 2to3 --no-diffs -w "${BUILD_DIR}"/tests/*.py || die
+ fi
+
+ nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp ${PN}
+}