summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-26 08:19:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-26 08:19:47 +0000
commit5325cb8e4dd19dd183e4d516ef8340d16f593c6e (patch)
tree145c6179695bdd5fb013b188980d6591f5463c2b /dev-python/pymongo
parentVersion bump. (diff)
downloadgentoo-2-5325cb8e4dd19dd183e4d516ef8340d16f593c6e.tar.gz
gentoo-2-5325cb8e4dd19dd183e4d516ef8340d16f593c6e.tar.bz2
gentoo-2-5325cb8e4dd19dd183e4d516ef8340d16f593c6e.zip
add py3.1 support, fix to test phase
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/ChangeLog6
-rw-r--r--dev-python/pymongo/pymongo-2.5.1.ebuild16
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/pymongo/ChangeLog b/dev-python/pymongo/ChangeLog
index bc5e6cc6c961..2f09ef25f9fa 100644
--- a/dev-python/pymongo/ChangeLog
+++ b/dev-python/pymongo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pymongo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.22 2013/05/24 08:17:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.23 2013/05/26 08:19:47 idella4 Exp $
+
+ 26 May 2013; Ian Delaney <idella4@gentoo.org> pymongo-2.5.1.ebuild,
+ pymongo-2.5.ebuild:
+ add py3.1 support, fix to test phase
24 May 2013; Ian Delaney <idella4@gentoo.org> pymongo-2.5.1.ebuild:
Add py3 support, adjust test phase accordingly
diff --git a/dev-python/pymongo/pymongo-2.5.1.ebuild b/dev-python/pymongo/pymongo-2.5.1.ebuild
index cdeba4ee8458..56b40d9b7463 100644
--- a/dev-python/pymongo/pymongo-2.5.1.ebuild
+++ b/dev-python/pymongo/pymongo-2.5.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.2 2013/05/24 08:17:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.1.ebuild,v 1.3 2013/05/26 08:19:47 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
inherit check-reqs distutils-r1
@@ -52,7 +52,7 @@ python_compile_all() {
src_test() {
# Yes, we need TCP/IP for that...
local DB_IP=127.0.0.1
- local DB_PORT=27017
+ local DB_PORT=27000
export DB_IP DB_PORT
@@ -77,7 +77,7 @@ python_test() {
LC_ALL=C \
mongod --dbpath "${dbpath}" --smallfiles --nojournal \
- --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --port ${DB_PORT} \
--unixSocketPrefix "${TMPDIR}" \
--logpath "${logpath}" --fork \
&& sleep 2
@@ -102,15 +102,11 @@ python_test() {
local failed
#https://jira.mongodb.org/browse/PYTHON-521
+ pushd "${BUILD_DIR}"/../ > /dev/null
if [[ "${EPYTHON}" == python3* ]]; then
- pushd build/lib > /dev/null
- mv ../../test . || die
2to3 --no-diffs -w test
- nosetests ./test || failed=1
- mv test ../../ || die
- else
- nosetests || failed=1
fi
+ esetup.py test || failed=1
mongod --dbpath "${dbpath}" --shutdown