summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-06-03 19:00:02 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-06-03 19:00:02 +0000
commit365485f3932e71a1657b3a8b9c34f3d9e39e4cac (patch)
tree791fad2f29fead3ec55be230eea95e04bb4a46d1 /dev-python/pyrax
parentMake last patch a rev bump. Thanks Arfrever for pointing out (diff)
downloadgentoo-2-365485f3932e71a1657b3a8b9c34f3d9e39e4cac.tar.gz
gentoo-2-365485f3932e71a1657b3a8b9c34f3d9e39e4cac.tar.bz2
gentoo-2-365485f3932e71a1657b3a8b9c34f3d9e39e4cac.zip
just a version bump for pyrax
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pyrax')
-rw-r--r--dev-python/pyrax/ChangeLog7
-rw-r--r--dev-python/pyrax/pyrax-1.4.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pyrax/ChangeLog b/dev-python/pyrax/ChangeLog
index 7d74f73a1481..469a2e1bb8ad 100644
--- a/dev-python/pyrax/ChangeLog
+++ b/dev-python/pyrax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyrax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.5 2013/04/03 15:56:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.6 2013/06/03 19:00:02 prometheanfire Exp $
+
+*pyrax-1.4.3 (03 Jun 2013)
+
+ 03 Jun 2013; Matthew Thode <prometheanfire@gentoo.org> +pyrax-1.4.3.ebuild:
+ just a version bump for pyrax
*pyrax-1.3.6 (03 Apr 2013)
diff --git a/dev-python/pyrax/pyrax-1.4.3.ebuild b/dev-python/pyrax/pyrax-1.4.3.ebuild
new file mode 100644
index 000000000000..5b55c5d842fb
--- /dev/null
+++ b/dev-python/pyrax/pyrax-1.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/pyrax-1.4.3.ebuild,v 1.1 2013/06/03 19:00:02 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python SDK for OpenStack/Rackspace APIs"
+HOMEPAGE="https://github.com/openstack/python-novaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}