summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-26 08:57:27 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-26 08:57:27 +0000
commitf525f093d316138314d187b8d9388b5620963c72 (patch)
treeaff3af1c3770304ac3e8f59c2cd4ca0405d7ae2b /dev-python/webob
parentadding anyjson-0.2.4 because sys-cluster/quantum requires it :( (diff)
downloadgentoo-2-f525f093d316138314d187b8d9388b5620963c72.tar.gz
gentoo-2-f525f093d316138314d187b8d9388b5620963c72.tar.bz2
gentoo-2-f525f093d316138314d187b8d9388b5620963c72.zip
adding webob-1.0.8 because sys-cluster/quantum requires it :(
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/ChangeLog9
-rw-r--r--dev-python/webob/webob-1.0.8.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 0b7364b96622..916f3e4774d8 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webob
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.60 2012/12/08 08:25:37 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.61 2013/01/26 08:57:27 prometheanfire Exp $
+
+*webob-1.0.8 (26 Jan 2013)
+
+ 26 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> +webob-1.0.8.ebuild:
+ adding webob-1.0.8 because sys-cluster/quantum requires it :(
09 Dec 2012; Ian Delaney <idella4@gentoo.org> webob-1.2.3.ebuild:
Fix dependencies. Suggested by Arfrever
diff --git a/dev-python/webob/webob-1.0.8.ebuild b/dev-python/webob/webob-1.0.8.ebuild
new file mode 100644
index 000000000000..cb5bac430940
--- /dev/null
+++ b/dev-python/webob/webob-1.0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8.ebuild,v 1.1 2013/01/26 08:57:27 prometheanfire Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="WebOb"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/webtest )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}