summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-11-27 16:13:24 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-11-27 16:13:24 +0000
commit98f4b40c5a4909cbc45221561e006e268f55fdac (patch)
treeb12b1f333f2ae99ab3dff254f3d9d27edf8857af /dev-python/wsgiintercept
parentVersion bump (diff)
downloadgentoo-2-98f4b40c5a4909cbc45221561e006e268f55fdac.tar.gz
gentoo-2-98f4b40c5a4909cbc45221561e006e268f55fdac.tar.bz2
gentoo-2-98f4b40c5a4909cbc45221561e006e268f55fdac.zip
Version bump, required for mwlib tests
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog9
-rw-r--r--dev-python/wsgiintercept/files/0.6.0-fix-tests.patch20
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild35
3 files changed, 62 insertions, 2 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 6a54a4f7133c..99672b903e9d 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.1 2013/07/03 13:14:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.2 2013/11/27 16:13:23 dev-zero Exp $
+
+*wsgiintercept-0.6.0 (27 Nov 2013)
+
+ 27 Nov 2013; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.6.0-fix-tests.patch, +wsgiintercept-0.6.0.ebuild:
+ Version bump, required for mwlib tests
*wsgiintercept-0.5.1 (03 Jul 2013)
03 Jul 2013; Justin Lecher <jlec@gentoo.org> +wsgiintercept-0.5.1.ebuild,
+metadata.xml:
New addition written by me
-
diff --git a/dev-python/wsgiintercept/files/0.6.0-fix-tests.patch b/dev-python/wsgiintercept/files/0.6.0-fix-tests.patch
new file mode 100644
index 000000000000..264ba4bf2810
--- /dev/null
+++ b/dev-python/wsgiintercept/files/0.6.0-fix-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/test/test_httplib2.py b/test/test_httplib2.py
+index 157fbc4..d7cecc5 100644
+--- a/test/test_httplib2.py
++++ b/test/test_httplib2.py
+@@ -1,5 +1,5 @@
+ from wsgi_intercept import httplib2_intercept
+-from socket import gaierror
++from socket import error
+ import wsgi_intercept
+ from test import wsgi_app
+ import httplib2
+@@ -30,7 +30,7 @@ def test_success():
+
+ def test_bogus_domain():
+ install()
+- py.test.raises(gaierror,
++ py.test.raises(error,
+ 'httplib2_intercept.HTTP_WSGIInterceptorWithTimeout("_nonexistant_domain_").connect()')
+ uninstall()
+
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild
new file mode 100644
index 000000000000..e0c47deaa4fb
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild,v 1.1 2013/11/27 16:13:23 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PV}-fix-tests.patch" )
+
+python_test() {
+ py.test || die
+}