summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 13:50:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 13:50:51 +0000
commit0635634f78a64371f6403e0f3b122923407fa376 (patch)
tree829d83b33eeaf4b7d15fe740b567d148c179c8f4 /dev-python/wtforms
parentBump (diff)
downloadgentoo-2-0635634f78a64371f6403e0f3b122923407fa376.tar.gz
gentoo-2-0635634f78a64371f6403e0f3b122923407fa376.tar.bz2
gentoo-2-0635634f78a64371f6403e0f3b122923407fa376.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/ChangeLog7
-rw-r--r--dev-python/wtforms/wtforms-1.0.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/wtforms/ChangeLog b/dev-python/wtforms/ChangeLog
index 4ab1c25e64b7..003a22c91f7c 100644
--- a/dev-python/wtforms/ChangeLog
+++ b/dev-python/wtforms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtforms
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.21 2012/05/21 09:33:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/ChangeLog,v 1.22 2012/10/09 13:50:51 patrick Exp $
+
+*wtforms-1.0.2 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +wtforms-1.0.2.ebuild:
+ Bump
21 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> wtforms-1.0.1.ebuild:
x86 stable wrt bug #415853
diff --git a/dev-python/wtforms/wtforms-1.0.2.ebuild b/dev-python/wtforms/wtforms-1.0.2.ebuild
new file mode 100644
index 000000000000..d4d5f5ea40df
--- /dev/null
+++ b/dev-python/wtforms/wtforms-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtforms/wtforms-1.0.2.ebuild,v 1.1 2012/10/09 13:50:51 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="WTForms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="http://wtforms.simplecodes.com/ http://pypi.python.org/pypi/WTForms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6 )"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt README.txt"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}